summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libdbusmenu/files/libdbusmenu-0.3.16-optional-tests.patch')
-rw-r--r--dev-libs/libdbusmenu/files/libdbusmenu-0.3.16-optional-tests.patch35
1 files changed, 23 insertions, 12 deletions
diff --git a/dev-libs/libdbusmenu/files/libdbusmenu-0.3.16-optional-tests.patch b/dev-libs/libdbusmenu/files/libdbusmenu-0.3.16-optional-tests.patch
index b0518717c1e8..e047cd83bfc4 100644
--- a/dev-libs/libdbusmenu/files/libdbusmenu-0.3.16-optional-tests.patch
+++ b/dev-libs/libdbusmenu/files/libdbusmenu-0.3.16-optional-tests.patch
@@ -1,34 +1,45 @@
--- configure.ac.orig 2010-09-20 21:51:50.289828895 +0200
+++ configure.ac 2010-09-20 22:01:21.623107607 +0200
-@@ -76,8 +76,15 @@
+@@ -76,8 +76,17 @@
JSON_GLIB_REQUIRED_VERSION=0.6.0
GIO_UNIX_REQUIRED_VERSION=2.24
+AC_ARG_ENABLE([tests],
+ AC_HELP_STRING([--disable-tests], [Disable tests]),
-+ [enable_tests=$enableval], enable_tests=auto)
++ [enable_tests=$enableval], [enable_tests=auto])
+AM_CONDITIONAL([WANT_TESTS], [test "x$enable_tests" != "xno"])
+
-+if test "x$enable_tests" != "xno" ; then
++AS_IF([test "x$enable_tests" != "xno"],[
PKG_CHECK_MODULES(DBUSMENUTESTS, json-glib-1.0 >= $JSON_GLIB_REQUIRED_VERSION
- gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION)
-+fi
+- gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION)
++ gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION,
++ [have_tests=yes]
++)
++])
AC_SUBST(DBUSMENUTESTS_CFLAGS)
AC_SUBST(DBUSMENUTESTS_LIBS)
+@@ -193,1 +193,6 @@
+
++AS_IF([test "x$have_tests" = "xyes"],
++ AC_MSG_NOTICE([ Tests: yes]),
++ AC_MSG_NOTICE([ Tests: no])
++)
++
--- Makefile.am.orig 2010-09-20 21:58:41.616751481 +0200
+++ Makefile.am 2010-09-20 22:01:55.525674385 +0200
-@@ -9,6 +9,9 @@
- tools \
-- tests \
- docs \
- po
+@@ -5,2 +5,6 @@
+if WANT_TESTS
-+SUBDIRS += tests
++TESTS_SUBDIR = tests
+endif
+
- DISTCHECK_CONFIGURE_FLAGS = --enable-introspection --enable-gtk-doc
+ SUBDIRS = \
+@@ -9,3 +9,3 @@
+ tools \
+- tests \
++ $(TESTS_SUBDIR) \
+ docs \
--- tools/testapp/Makefile.am.orig 2011-01-29 13:42:00.984605528 +0100
+++ tools/testapp/Makefile.am 2011-01-29 13:44:45.523514281 +0100
@@ -1,5 +1,9 @@