summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libnl/libnl-3.2.9.ebuild')
-rw-r--r--dev-libs/libnl/libnl-3.2.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/libnl/libnl-3.2.9.ebuild b/dev-libs/libnl/libnl-3.2.9.ebuild
new file mode 100644
index 000000000000..47b02fcc1d71
--- /dev/null
+++ b/dev-libs/libnl/libnl-3.2.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/libnl-3.2.9.ebuild,v 1.1 2012/05/12 15:24:40 jer Exp $
+
+EAPI=4
+inherit autotools eutils multilib
+
+DESCRIPTION="A library for applications dealing with netlink socket"
+HOMEPAGE="http://www.infradead.org/~tgr/libnl/"
+SRC_URI="http://www.infradead.org/~tgr/libnl/files/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="doc static-libs utils"
+
+DEPEND="
+ sys-devel/flex
+ virtual/yacc
+ doc? ( app-doc/doxygen[latex] )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1-vlan-header.patch
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) $(use_enable utils cli)
+}
+
+src_compile() {
+ default
+ use doc && emake -C doc api_ref
+}
+
+src_install() {
+ default
+ if use doc; then
+ dohtml doc/api/*
+ fi
+
+ if ! use static-libs; then
+ rm -f "${D}"/usr/lib*/lib*.la
+ fi
+
+ dodoc ChangeLog
+}