summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/ChangeLog8
-rw-r--r--dev-libs/openssl/files/digest-openssl-0.9.7j3
-rw-r--r--dev-libs/openssl/files/digest-openssl-0.9.8b3
-rw-r--r--dev-libs/openssl/files/openssl-0.9.8b-parallel-build.patch23
-rw-r--r--dev-libs/openssl/openssl-0.9.7j.ebuild172
-rw-r--r--dev-libs/openssl/openssl-0.9.8b.ebuild157
6 files changed, 365 insertions, 1 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index 5337d8296097..33eec35f4a2e 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/openssl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.159 2006/05/05 14:51:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.160 2006/05/05 14:53:48 vapier Exp $
+
+*openssl-0.9.8b (05 May 2006)
+
+ 05 May 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/openssl-0.9.8b-parallel-build.patch, +openssl-0.9.8b.ebuild:
+ Version bump.
*openssl-0.9.7j (05 May 2006)
diff --git a/dev-libs/openssl/files/digest-openssl-0.9.7j b/dev-libs/openssl/files/digest-openssl-0.9.7j
new file mode 100644
index 000000000000..f624403f8651
--- /dev/null
+++ b/dev-libs/openssl/files/digest-openssl-0.9.7j
@@ -0,0 +1,3 @@
+MD5 79dd939266b069e7aca587e6ab16a055 openssl-0.9.7j.tar.gz 3290510
+RMD160 b8959f59ca9861ce2981641bb74022239677bf7e openssl-0.9.7j.tar.gz 3290510
+SHA256 65a6e88c3397cb68d19dbb576ecf9f9d8dc41423aa9ac3025cd29e3987274460 openssl-0.9.7j.tar.gz 3290510
diff --git a/dev-libs/openssl/files/digest-openssl-0.9.8b b/dev-libs/openssl/files/digest-openssl-0.9.8b
new file mode 100644
index 000000000000..a19637f1b7dc
--- /dev/null
+++ b/dev-libs/openssl/files/digest-openssl-0.9.8b
@@ -0,0 +1,3 @@
+MD5 12cedbeb6813a0d7919dbf1f82134b86 openssl-0.9.8b.tar.gz 3279283
+RMD160 861e0e390529e5dca418e277678c93a776b524bc openssl-0.9.8b.tar.gz 3279283
+SHA256 69efed6275942f9312de61cf69aaef12b06c12f6b10f319672ce026a756f65c0 openssl-0.9.8b.tar.gz 3279283
diff --git a/dev-libs/openssl/files/openssl-0.9.8b-parallel-build.patch b/dev-libs/openssl/files/openssl-0.9.8b-parallel-build.patch
new file mode 100644
index 000000000000..64cc8ef1493b
--- /dev/null
+++ b/dev-libs/openssl/files/openssl-0.9.8b-parallel-build.patch
@@ -0,0 +1,23 @@
+--- openssl-0.9.8b/Makefile.org
++++ openssl-0.9.8b/Makefile.org
+@@ -229,15 +229,15 @@
+
+ build_crypto:
+ @dir=crypto; target=all; $(BUILD_ONE_CMD)
+-build_ssl:
++build_ssl: build_crypto
+ @dir=ssl; target=all; $(BUILD_ONE_CMD)
+-build_engines:
++build_engines: build_crypto
+ @dir=engines; target=all; $(BUILD_ONE_CMD)
+-build_apps:
++build_apps: build_libs
+ @dir=apps; target=all; $(BUILD_ONE_CMD)
+-build_tests:
++build_tests: build_libs
+ @dir=test; target=all; $(BUILD_ONE_CMD)
+-build_tools:
++build_tools: build_libs
+ @dir=tools; target=all; $(BUILD_ONE_CMD)
+
+ all_testapps: build_libs build_testapps
diff --git a/dev-libs/openssl/openssl-0.9.7j.ebuild b/dev-libs/openssl/openssl-0.9.7j.ebuild
new file mode 100644
index 000000000000..22fd27b65aa4
--- /dev/null
+++ b/dev-libs/openssl/openssl-0.9.7j.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7j.ebuild,v 1.1 2006/05/05 14:51:01 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
+HOMEPAGE="http://www.openssl.org/"
+SRC_URI="mirror://openssl/source/${P}.tar.gz"
+
+LICENSE="openssl"
+SLOT="0"
+# make sure your arch is ABI compat before adding KEYWORD back in
+KEYWORDS="-* ~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs test bindist zlib"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-apps/diffutils
+ >=dev-lang/perl-5
+ test? ( sys-devel/bc )"
+PDEPEND="app-misc/ca-certificates"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-0.9.7g-ppc64.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7e-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7-hppa-fix-detection.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7-alpha-default-gcc.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7g-mem-clr-ptr-cast.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7h-ABI-compat.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7g-superh.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7i-m68k.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7g-amd64-fbsd.patch
+
+ # allow openssl to be cross-compiled
+ cp "${FILESDIR}"/gentoo.config-0.9.7g gentoo.config || die "cp cross-compile failed"
+ chmod a+rx gentoo.config
+
+ # Don't build manpages if we don't want them
+ has noman FEATURES && sed -i '/^install:/s:install_docs::' Makefile.org
+
+ case $(gcc-version) in
+ 3.2)
+ filter-flags -fprefetch-loop-arrays -freduce-all-givs -funroll-loop
+ ;;
+ 3.4 | 3.3 )
+ filter-flags -fprefetch-loop-arrays -freduce-all-givs -funroll-loops
+ [[ ${ARCH} == "ppc" || ${ARCH} == "ppc64" ]] && append-flags -fno-strict-aliasing
+ ;;
+ esac
+ append-flags -Wa,--noexecstack
+
+ # replace CFLAGS
+ OLDIFS=$IFS
+ IFS=$'\n'
+ for a in $( grep -n -e "^\"linux-" Configure ); do
+ LINE=$( echo $a | awk -F: '{print $1}' )
+ CUR_CFLAGS=$( echo $a | awk -F: '{print $3}' )
+ NEW_CFLAGS=$(echo $CUR_CFLAGS | LC_ALL=C sed -r -e "s|-O[23]||" -e "s:-fomit-frame-pointer::" -e "s:-mcpu=[-a-z0-9]+::" -e "s:-m486::")
+ # ppc64's current toolchain sucks at optimization and will break this package
+ [[ $(tc-arch) != "ppc64" ]] && NEW_CFLAGS="${NEW_CFLAGS} ${CFLAGS}"
+
+ sed -i "${LINE}s:$CUR_CFLAGS:$NEW_CFLAGS:" Configure || die "sed failed"
+ done
+ IFS=$OLDIFS
+
+ if [ "$(get_libdir)" != "lib" ] ; then
+ # using a library directory other than lib requires some magic
+ sed -i \
+ -e "s+\(\$(INSTALL_PREFIX)\$(INSTALLTOP)\)/lib+\1/$(get_libdir)+g" \
+ -e "s+libdir=\$\${exec_prefix}/lib+libdir=\$\${exec_prefix}/$(get_libdir)+g" \
+ Makefile.org \
+ || die "sed failed"
+ ./config --test-sanity || die "sanity failed"
+ fi
+}
+
+src_compile() {
+ # Clean out patent-or-otherwise-encumbered code.
+ # MDC-2: 4,908,861 13/03/2007
+ # IDEA: 5,214,703 25/05/2010
+ # RC5: 5,724,428 03/03/2015
+ # EC: ????????? ??/??/2015
+ local confopts=""
+ use bindist && confopts="no-idea no-rc5 no-mdc2 -no-ec"
+
+ use zlib && confopts="${confopts} zlib-dynamic"
+
+ local sslout=$(./gentoo.config)
+ einfo "Use configuration ${sslout}"
+
+ local config="Configure"
+ [[ -z ${sslout} ]] && config="config"
+ ./${config} \
+ ${sslout} \
+ ${confopts} \
+ --prefix=/usr \
+ --openssldir=/etc/ssl \
+ shared threads \
+ || die "Configure failed"
+
+ emake \
+ CC="$(tc-getCC)" MAKEDEPPROG="$(tc-getCC)" \
+ AR="$(tc-getAR) r" \
+ RANLIB="$(tc-getRANLIB)" \
+ all || die "make all failed"
+
+ # force until we get all the gentoo.config kinks worked out
+ tc-is-cross-compiler || src_test
+}
+
+src_test() {
+ # make sure sandbox doesnt die on *BSD
+ add_predict /dev/crypto
+
+ make test || die "make test failed"
+}
+
+src_install() {
+ make INSTALL_PREFIX="${D}" MANDIR=/usr/share/man install || die
+ dodoc CHANGES* FAQ NEWS README
+ dodoc doc/*.txt
+ dohtml doc/*
+
+ if use emacs ; then
+ insinto /usr/share/emacs/site-lisp
+ doins doc/c-indentation.el
+ fi
+
+ # create the certs directory. Previous openssl builds
+ # would need to create /usr/lib/ssl/certs but this looks
+ # to be the more FHS compliant setup... -raker
+ insinto /etc/ssl/certs
+ doins certs/*.pem
+ LD_LIBRARY_PATH="${D}"/usr/$(get_libdir)/ \
+ OPENSSL="${D}"/usr/bin/openssl /usr/bin/perl tools/c_rehash "${D}"/etc/ssl/certs
+
+ # These man pages with other packages so rename them
+ cd "${D}"/usr/share/man
+ for m in man1/passwd.1 man3/rand.3 man3/err.3 ; do
+ d=${m%%/*} ; m=${m##*/}
+ mv ${d}/{,ssl-}${m}
+ ln -s ssl-${m} ${d}/openssl-${m}
+ done
+
+ fperms a+x /usr/$(get_libdir)/pkgconfig #34088
+}
+
+pkg_postinst() {
+ local BN_H="${ROOT}$(gcc-config -L)/include/openssl/bn.h"
+ # Breaks things one some boxen, bug #13795. The problem is that
+ # if we have a 'gcc fixed' version in $(gcc-config -L) from 0.9.6,
+ # then breaks as it was defined as 'int BN_mod(...)' and in 0.9.7 it
+ # is a define with BN_div(...) - <azarah@gentoo.org> (24 Sep 2003)
+ if [ -f "${BN_H}" ] && [ -n "$(grep '^int[[:space:]]*BN_mod(' "${BN_H}")" ]
+ then
+ rm -f "${BN_H}"
+ fi
+
+ if [[ -e ${ROOT}/usr/lib/libcrypto.so.0.9.6 ]] ; then
+ ewarn "You must re-compile all packages that are linked against"
+ ewarn "OpenSSL 0.9.6 by using revdep-rebuild from gentoolkit:"
+ ewarn "# revdep-rebuild --library libssl.so.0.9.6"
+ ewarn "# revdep-rebuild --library libcrypto.so.0.9.6"
+ ewarn "After this, you can delete /usr/lib/libssl.so.0.9.6 and /usr/lib/libcrypto.so.0.9.6"
+ touch -c "${ROOT}"/usr/lib/lib{crypto,ssl}.so.0.9.6
+ fi
+}
diff --git a/dev-libs/openssl/openssl-0.9.8b.ebuild b/dev-libs/openssl/openssl-0.9.8b.ebuild
new file mode 100644
index 000000000000..357f24449a89
--- /dev/null
+++ b/dev-libs/openssl/openssl-0.9.8b.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8b.ebuild,v 1.1 2006/05/05 14:53:48 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
+HOMEPAGE="http://www.openssl.org/"
+SRC_URI="mirror://openssl/source/${P}.tar.gz"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="-*"
+IUSE="emacs test bindist zlib"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-apps/diffutils
+ >=dev-lang/perl-5
+ test? ( sys-devel/bc )"
+PDEPEND="app-misc/ca-certificates"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-0.9.8-ppc64.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7e-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-0.9.8-hppa-fix-detection.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7-alpha-default-gcc.patch
+ epatch "${FILESDIR}"/${PN}-0.9.8b-parallel-build.patch
+ epatch "${FILESDIR}"/${PN}-0.9.8-make-engines-dir.patch
+ epatch "${FILESDIR}"/${PN}-0.9.8-toolchain.patch
+
+ # allow openssl to be cross-compiled
+ cp "${FILESDIR}"/gentoo.config-0.9.8 gentoo.config || die "cp cross-compile failed"
+ chmod a+rx gentoo.config
+
+ # Don't build manpages if we don't want them
+ has noman FEATURES \
+ && sed -i '/^install:/s:install_docs::' Makefile.org \
+ || sed -i '/^MANDIR=/s:=.*:=/usr/share/man:' Makefile.org
+
+ # Try to derice users
+ [[ $(gcc-major-version) == "3" ]] \
+ && filter-flags -fprefetch-loop-arrays -freduce-all-givs -funroll-loops
+ [[ $(tc-arch) == ppc* ]] && append-flags -fno-strict-aliasing
+ append-flags -Wa,--noexecstack
+
+ # using a library directory other than lib requires some magic
+ sed -i \
+ -e "s+\(\$(INSTALL_PREFIX)\$(INSTALLTOP)\)/lib+\1/$(get_libdir)+g" \
+ -e "s+libdir=\$\${exec_prefix}/lib+libdir=\$\${exec_prefix}/$(get_libdir)+g" \
+ Makefile.org engines/Makefile \
+ || die "sed failed"
+ ./config --test-sanity || die "I AM NOT SANE"
+}
+
+src_compile() {
+ tc-export CC AR RANLIB
+
+ # Clean out patent-or-otherwise-encumbered code
+ # MDC-2: 4,908,861 13/03/2007
+ # IDEA: 5,214,703 25/05/2010
+ # RC5: 5,724,428 03/03/2015
+ # EC: ????????? ??/??/2015
+ local confopts=""
+ if use bindist ; then
+ confopts="no-idea no-rc5 no-mdc2 no-ec"
+ else
+ confopts="enable-idea enable-rc5 enable-mdc2 enable-ec"
+ fi
+ use zlib && confopts="${confopts} zlib-dynamic"
+
+ local sslout=$(./gentoo.config)
+ einfo "Use configuration ${sslout:-(openssl knows best)}"
+ local config="Configure"
+ [[ -z ${sslout} ]] && config="config"
+ ./${config} \
+ ${sslout} \
+ ${confopts} \
+ --prefix=/usr \
+ --openssldir=/etc/ssl \
+ shared threads \
+ || die "Configure failed"
+
+ # Clean out hardcoded flags that openssl uses
+ local CFLAG=$(grep ^CFLAG= Makefile | LC_ALL=C sed \
+ -e 's:^CFLAG=::' \
+ -e 's:-fomit-frame-pointer ::g' \
+ -e 's:-O[0-9] ::g' \
+ -e 's:-march=[-a-z0-9]* ::g' \
+ -e 's:-mcpu=[-a-z0-9]* ::g' \
+ -e 's:-m[a-z0-9]* ::g' \
+ )
+ sed -i -e "/^CFLAG/s:=.*:=${CFLAG} ${CFLAGS}:" Makefile || die
+
+ # depend is needed to use $confopts
+ # rehash is needed to prep the certs/ dir
+ emake -j1 depend || die "depend failed"
+ emake all rehash || die "make all failed"
+
+ # force until we get all the gentoo.config kinks worked out
+ src_test
+}
+
+src_test() {
+ tc-is-cross-compiler && return 0
+
+ # make sure sandbox doesnt die on *BSD
+ add_predict /dev/crypto
+
+ make test || die "make test failed"
+}
+
+src_install() {
+ make INSTALL_PREFIX="${D}" install || die
+ dodoc CHANGES* FAQ NEWS README
+ dodoc doc/*.txt
+ dohtml doc/*
+
+ if use emacs ; then
+ insinto /usr/share/emacs/site-lisp
+ doins doc/c-indentation.el
+ fi
+
+ # create the certs directory
+ dodir /etc/ssl/certs
+ cp -RP certs/* "${D}"/etc/ssl/certs/ || die "failed to install certs"
+ rm -r "${D}"/etc/ssl/certs/{demo,expired}
+
+ # These man pages conflict with other packages so rename them
+ cd "${D}"/usr/share/man
+ for m in man1/passwd.1 man3/rand.3 man3/err.3 ; do
+ d=${m%%/*} ; m=${m##*/}
+ mv -f ${d}/{,ssl-}${m}
+ ln -snf ssl-${m} ${d}/openssl-${m}
+ done
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/usr/$(get_libdir)/libcrypto.so.0.9.7 ]] ; then
+ cp -pPR "${ROOT}"/usr/$(get_libdir)/lib{crypto,ssl}.so.0.9.7 "${IMAGE}"/usr/$(get_libdir)/
+ fi
+}
+
+pkg_postinst() {
+ if [[ -e ${ROOT}/usr/$(get_libdir)/libcrypto.so.0.9.7 ]] ; then
+ ewarn "You must re-compile all packages that are linked against"
+ ewarn "OpenSSL 0.9.7 by using revdep-rebuild from gentoolkit:"
+ ewarn "# revdep-rebuild --library libssl.so.0.9.7"
+ ewarn "# revdep-rebuild --library libcrypto.so.0.9.7"
+ ewarn "After this, you can delete /usr/$(get_libdir)/libssl.so.0.9.7"
+ ewarn "and /usr/$(get_libdir)/libcrypto.so.0.9.7"
+ fi
+}