summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-ltk/cl-ltk-0.8.5.ebuild')
-rw-r--r--dev-lisp/cl-ltk/cl-ltk-0.8.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-lisp/cl-ltk/cl-ltk-0.8.5.ebuild b/dev-lisp/cl-ltk/cl-ltk-0.8.5.ebuild
new file mode 100644
index 000000000000..677e49c3315b
--- /dev/null
+++ b/dev-lisp/cl-ltk/cl-ltk-0.8.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ltk/cl-ltk-0.8.5.ebuild,v 1.1 2004/07/06 18:50:23 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="LTK is a Common Lisp binding for the Tk graphics toolkit whick does not require any Tk knowledge for its usage."
+HOMEPAGE="http://www.peter-herth.de/ltk/"
+SRC_URI="http://www.peter-herth.de/ltk/${P#cl-}.tgz"
+
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=ltk
+
+S=${WORKDIR}/${PN#cl-}
+
+src_install() {
+ common-lisp-install *.lisp ltk.asd remote.tcl
+ common-lisp-system-symlink
+ dodoc *.{txt,pdf}
+}