summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/sbcl/sbcl-0.9.8.ebuild')
-rw-r--r--dev-lisp/sbcl/sbcl-0.9.8.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-lisp/sbcl/sbcl-0.9.8.ebuild b/dev-lisp/sbcl/sbcl-0.9.8.ebuild
index bd6283a1ca41..61eb6b5382fc 100644
--- a/dev-lisp/sbcl/sbcl-0.9.8.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.9.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.9.8.ebuild,v 1.3 2006/01/07 21:35:48 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.9.8.ebuild,v 1.4 2006/01/29 05:02:47 mkennedy Exp $
inherit common-lisp-common-2 eutils
@@ -23,7 +23,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~amd64"
-IUSE="hardened ldb nosource threads unicode"
+IUSE="hardened ldb nosource threads nptl unicode"
DEPEND="=dev-lisp/common-lisp-controller-4*
>=dev-lisp/cl-asdf-1.84
@@ -44,9 +44,16 @@ must use gcc-config to select a profile with non-hardened features
EOF
die
fi
+ if ! use nptl && (use x86 || use amd64); then
+ while read line; do einfo "${line}"; done <<'EOF'
+
+Building SBCL without NPTL support on at least x86 and amd64
+architectures is not a supported configuration in Gentoo. Please
+refer to Bug #119016 for more information.
- # FIXME Maybe something should be done in the case where a user requests
- # threads on a non-NPTL system
+EOF
+ die
+ fi
}
src_unpack() {