summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ulex/ulex-0.4.ebuild')
-rw-r--r--dev-ml/ulex/ulex-0.4.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/dev-ml/ulex/ulex-0.4.ebuild b/dev-ml/ulex/ulex-0.4.ebuild
index 35801681caba..4fb68b50d5ce 100644
--- a/dev-ml/ulex/ulex-0.4.ebuild
+++ b/dev-ml/ulex/ulex-0.4.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ulex/ulex-0.4.ebuild,v 1.1 2004/08/08 07:11:03 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ulex/ulex-0.4.ebuild,v 1.2 2004/08/25 13:36:53 mattam Exp $
-inherit eutils
+inherit eutils findlib
-DESCRIPTION="a lexer generator for unicode"
+DESCRIPTION="A lexer generator for unicode"
HOMEPAGE="http://www.cduce.org"
SRC_URI="http://www.cduce.org/download/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="x86 ppc"
IUSE=""
DEPEND=">=dev-lang/ocaml-3.06
-!>=dev-lang/ocaml-3.08
- >=dev-ml/findlib-0.8"
+!>=dev-lang/ocaml-3.08"
src_compile() {
make all || die
@@ -23,9 +22,6 @@ src_compile() {
}
src_install() {
- local destdir=`ocamlfind printconf destdir`
- dodir ${destdir}
- # dummy ld.conf, packages do not install C libraries
- make OCAMLFIND_LDCONF=dummy OCAMLFIND_DESTDIR=${D}${destdir} install || die
+ findlib_src_install
dodoc README CHANGES
}