summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/alembic/alembic-0.5.0.ebuild')
-rw-r--r--dev-python/alembic/alembic-0.5.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/alembic/alembic-0.5.0.ebuild b/dev-python/alembic/alembic-0.5.0.ebuild
new file mode 100644
index 000000000000..b56c6dc0cc73
--- /dev/null
+++ b/dev-python/alembic/alembic-0.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/alembic/alembic-0.5.0.ebuild,v 1.1 2013/06/13 03:33:28 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+RDEPEND=">=dev-python/sqlalchemy-0.7.9
+ dev-python/mako
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ cp -r test.cfg tests "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ if [[ ${EPYTHON} == python3* ]]; then
+ 2to3 -w -n tests || die
+ fi
+ nosetests || die "Testing failed with ${EPYTHON}"
+}