summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/coverage/coverage-3.4_beta2.ebuild')
-rw-r--r--dev-python/coverage/coverage-3.4_beta2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/coverage/coverage-3.4_beta2.ebuild b/dev-python/coverage/coverage-3.4_beta2.ebuild
new file mode 100644
index 000000000000..a540828c3b84
--- /dev/null
+++ b/dev-python/coverage/coverage-3.4_beta2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/coverage/coverage-3.4_beta2.ebuild,v 1.1 2010/09/17 20:51:05 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_P="${PN}-${PV/_beta/b}"
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="http://nedbatchelder.com/code/coverage/ http://pypi.python.org/pypi/coverage"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+PYTHON_MODNAME="coverage"