summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonschema/jsonschema-2.0.0.ebuild')
-rw-r--r--dev-python/jsonschema/jsonschema-2.0.0.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-python/jsonschema/jsonschema-2.0.0.ebuild b/dev-python/jsonschema/jsonschema-2.0.0.ebuild
deleted file mode 100644
index fb927ee8fef1..000000000000
--- a/dev-python/jsonschema/jsonschema-2.0.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonschema/jsonschema-2.0.0.ebuild,v 1.3 2014/03/31 20:34:30 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-inherit distutils-r1
-
-DESCRIPTION="An implementation of JSON-Schema validation for Python"
-HOMEPAGE="http://pypi.python.org/pypi/jsonschema"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-python_test() {
- local runner=( "${PYTHON}" -m unittest )
- if [[ ${EPYTHON} == python2.6 || ${EPYTHON} == python3.1 ]]; then
- unset PYTHONPATH
- runner=( unit2.py )
- fi
- "${runner[@]}" discover || die "Testing failed with ${EPYTHON}"
-}