summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/myghty/myghty-1.1.ebuild')
-rw-r--r--dev-python/myghty/myghty-1.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/myghty/myghty-1.1.ebuild b/dev-python/myghty/myghty-1.1.ebuild
new file mode 100644
index 000000000000..f6d819f37ff2
--- /dev/null
+++ b/dev-python/myghty/myghty-1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/myghty/myghty-1.1.ebuild,v 1.1 2007/02/27 23:49:39 dev-zero Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+MY_PN=Myghty
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Template and view-controller framework derived from HTML::Mason."
+HOMEPAGE="http://www.myghty.org"
+SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/routes-1.0
+ dev-python/paste
+ dev-python/pastedeploy
+ dev-python/pastescript"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/use_setuptools/d' \
+ -e '/install_requires=\[.*\],/d' \
+ setup.py || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc ; then
+ einfo "Generation docs as requested..."
+ cd doc
+ PYTHONPATH=./lib/ python genhtml.py || die "generating docs failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml doc/html/*
+}
+
+src_test() {
+ PYTHONPATH=./lib/ "${python}" test/alltests.py || die "tests failed"
+}