summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylint/pylint-0.2.1.ebuild')
-rw-r--r--dev-python/pylint/pylint-0.2.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pylint/pylint-0.2.1.ebuild b/dev-python/pylint/pylint-0.2.1.ebuild
new file mode 100644
index 000000000000..b3f089364963
--- /dev/null
+++ b/dev-python/pylint/pylint-0.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.2.1.ebuild,v 1.1 2003/10/14 18:23:58 liquidx Exp $
+
+inherit distutils
+
+DESCRIPTION="PyLint is a python tool that checks if a module satisfy a coding standard"
+SRC_URI="ftp://ftp.logilab.org/pub/pylint/${P}.tar.gz"
+HOMEPAGE="http://www.logilab.org/projects/pylint/"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+DEPEND=""
+
+PYTHON_MODNAME="logilab"
+DOCS="doc/*"
+
+src_install() {
+ distutils_src_install
+
+ # prevent multiple packages owning this dummy package
+ python_version
+ rm -f ${D}/usr/lib/python${PYVER}/site-packages/logilab/__init__.py
+}