summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pymongo/pymongo-2.5.1.ebuild')
-rw-r--r--dev-python/pymongo/pymongo-2.5.1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/pymongo/pymongo-2.5.1.ebuild b/dev-python/pymongo/pymongo-2.5.1.ebuild
index 59772b075451..70c9c0612011 100644
--- a/dev-python/pymongo/pymongo-2.5.1.ebuild
+++ b/dev-python/pymongo/pymongo-2.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.5.1.ebuild,v 1.5 2013/05/27 07:49:42 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.5.1.ebuild,v 1.6 2013/05/28 18:24:32 idella4 Exp $
EAPI=5
@@ -42,6 +42,8 @@ pkg_setup() {
reqcheck pkg_setup
}
+PATCHES=( "${FILESDIR}"/${P}-greenlet.patch )
+
python_compile_all() {
if use doc; then
mkdir html || die
@@ -105,9 +107,6 @@ python_test() {
pushd "${BUILD_DIR}"/../ > /dev/null
if [[ "${EPYTHON}" == python3* ]]; then
2to3 --no-diffs -w test
- elif [[ "${EPYTHON}" == 'python2.7' || "${EPYTHON}" == 'python2.6' ]]; then
- sed -e 's:test_socket_reclamation:_&:' \
- -i test/test_pooling_base.py || die
fi
DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1