summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyzmq/pyzmq-2.1.10.ebuild')
-rw-r--r--dev-python/pyzmq/pyzmq-2.1.10.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyzmq/pyzmq-2.1.10.ebuild b/dev-python/pyzmq/pyzmq-2.1.10.ebuild
new file mode 100644
index 000000000000..731b951b192e
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-2.1.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.1.10.ebuild,v 1.1 2011/10/17 15:33:26 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=net-libs/zeromq-2.1.9"
+DEPEND="${RDEPEND}"
+
+DOCS="README.rst"
+PYTHON_MODNAME="zmq"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests -sv $(ls -d build-${PYTHON_ABI}/lib.*)
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}