summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/setuptools/setuptools-0.6.30.ebuild')
-rw-r--r--dev-python/setuptools/setuptools-0.6.30.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/setuptools/setuptools-0.6.30.ebuild b/dev-python/setuptools/setuptools-0.6.30.ebuild
new file mode 100644
index 000000000000..dc99eea09eea
--- /dev/null
+++ b/dev-python/setuptools/setuptools-0.6.30.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.30.ebuild,v 1.1 2012/10/22 10:56:16 radhermit Exp $
+
+EAPI="4"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
+
+MY_PN="distribute"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Distribute (fork of Setuptools) is a collection of extensions to Distutils"
+HOMEPAGE="http://pypi.python.org/pypi/distribute"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="README.txt docs/easy_install.txt docs/pkg_resources.txt docs/setuptools.txt"
+PYTHON_MODNAME="easy_install.py pkg_resources.py setuptools site.py"
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${PN}-0.6_rc7-noexe.patch"
+ epatch "${FILESDIR}/distribute-0.6.16-fix_deprecation_warnings.patch"
+
+ # Disable tests requiring network connection.
+ rm -f setuptools/tests/test_packageindex.py
+}
+
+src_test() {
+ # test_install_site_py fails with disabled byte-compiling in Python 2.7 / >=3.2.
+ python_enable_pyc
+
+ distutils_src_test
+
+ python_disable_pyc
+ find "(" -name "*.pyc" -o -name "*\$py.class" ")" -exec rm -f {} +
+ find -name "__pycache__" -exec rmdir {} +
+}
+
+src_install() {
+ DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT="1" DONT_PATCH_SETUPTOOLS="1" distutils_src_install
+}