summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sip/sip-4.6.ebuild')
-rw-r--r--dev-python/sip/sip-4.6.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/sip/sip-4.6.ebuild b/dev-python/sip/sip-4.6.ebuild
new file mode 100644
index 000000000000..a32b3c6d0c7c
--- /dev/null
+++ b/dev-python/sip/sip-4.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.6.ebuild,v 1.1 2007/05/10 15:29:20 caleb Exp $
+
+NEED_PYTHON=2.3
+
+inherit python toolchain-funcs versionator
+
+MY_P=${P/_}
+
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/sip$(get_major_version)/${MY_P}.tar.gz"
+
+LICENSE="sip"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND=""
+RDEPEND=""
+
+src_compile(){
+ python_version
+
+ local myconf
+ use debug && myconf="${myconf} -u"
+
+ python configure.py \
+ -b "${ROOT}usr/bin" \
+ -d "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages" \
+ -e "${ROOT}usr/include/python${PYVER}" \
+ -v "${ROOT}usr/share/sip" \
+ ${myconf} \
+ CXXFLAGS_RELEASE="" CFLAGS_RELEASE="" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ CC=$(tc-getCC) CXX=$(tc-getCXX) \
+ LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX) \
+ STRIP="/bin/true" || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog NEWS README THANKS TODO doc/sipref.txt
+ dohtml doc/*
+}
+
+pkg_postinst() {
+ python_mod_optimize
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}