summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/fxruby/fxruby-1.6.18.ebuild')
-rw-r--r--dev-ruby/fxruby/fxruby-1.6.18.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/dev-ruby/fxruby/fxruby-1.6.18.ebuild b/dev-ruby/fxruby/fxruby-1.6.18.ebuild
index 351c5447d2c3..feed7abc7d43 100644
--- a/dev-ruby/fxruby/fxruby-1.6.18.ebuild
+++ b/dev-ruby/fxruby/fxruby-1.6.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.18.ebuild,v 1.1 2009/01/01 11:32:18 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.18.ebuild,v 1.2 2009/01/01 15:47:44 mabi Exp $
RUBY_BUG_145222=yes
inherit ruby
@@ -9,16 +9,16 @@ MY_P="FXRuby-${PV}"
DESCRIPTION="Ruby language binding to the FOX GUI toolkit"
HOMEPAGE="http://www.fxruby.org/"
-SRC_URI="http://rubyforge.org/frs/download.php/49263/${MY_P}.tar.gz"
+SRC_URI="mirror://rubyforge/${PN}/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="1.6"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
IUSE="examples doc"
DEPEND="=x11-libs/fox-1.6*
>=x11-libs/fxscintilla-1.62-r1"
-USE_RUBY="ruby16 ruby18 ruby19"
+USE_RUBY="ruby18 ruby19"
S="${WORKDIR}/${MY_P}"
@@ -32,3 +32,12 @@ src_unpack() {
sed -i -e 's:-O0 -Iinclude:-Iinclude:g' \
ext/fox16/extconf.rb || die "Can't fix forced -O0"
}
+
+src_install() {
+ ${RUBY} install.rb config --prefix="${D}/usr" "$@" \
+ ${RUBY_ECONF} || die "install.rb config failed"
+
+ ${RUBY} install.rb install "$@" --prefix="${D}" \
+ ${RUBY_ECONF} || die "install.rb install failed"
+}
+