summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/libxml/libxml-0.9.5.ebuild')
-rw-r--r--dev-ruby/libxml/libxml-0.9.5.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/libxml/libxml-0.9.5.ebuild b/dev-ruby/libxml/libxml-0.9.5.ebuild
new file mode 100644
index 000000000000..bb661f575028
--- /dev/null
+++ b/dev-ruby/libxml/libxml-0.9.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-0.9.5.ebuild,v 1.1 2008/11/30 11:52:40 flameeyes Exp $
+
+inherit ruby
+
+MY_P=${PN}-ruby-${PV}
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="http://libxml.rubyforge.org"
+SRC_URI="mirror://rubyforge/${PN}/${MY_P}.tgz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="" # doc
+
+RDEPEND=">=dev-libs/libxml2-2.6.6"
+DEPEND="${RDEPEND}
+ dev-ruby/rake"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ rake extensions || die "rake extensions failed"
+
+ # Does not work on 0.9.5
+ #if use doc; then
+ # rake rdoc || die "rake rdoc failed"
+ #fi
+}
+
+src_test() {
+ rake test || die "rake test failed"
+}
+
+src_install() {
+ cd "${S}"/lib
+ doruby -r * || die "doruby failed"
+
+ cd "${S}"/ext/libxml
+ ruby_einstall || die "ruby_einstall failed"
+
+ cd "${S}"
+
+ dodoc README CHANGES || die "dodoc failed"
+
+ #if use doc; then
+ # dohtml -r doc/* || die "dohtml failed"
+ #fi
+}