summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/monodoc/monodoc-0.17.ebuild')
-rw-r--r--dev-util/monodoc/monodoc-0.17.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/monodoc/monodoc-0.17.ebuild b/dev-util/monodoc/monodoc-0.17.ebuild
new file mode 100644
index 000000000000..01f9f69e5a0e
--- /dev/null
+++ b/dev-util/monodoc/monodoc-0.17.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodoc/monodoc-0.17.ebuild,v 1.1 2004/06/16 05:50:59 latexer Exp $
+
+inherit mono
+
+DESCRIPTION="Documentation for mono's .Net class library"
+HOMEPAGE="http://www.go-mono.com"
+SRC_URI="http://www.go-mono.com/archive/beta3/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND=">=dev-dotnet/mono-0.96
+ >=x11-libs/gtk-sharp-0.98"
+
+src_compile() {
+ econf || die
+ MAKEOPTS="-j1"
+ make || {
+ echo
+ ewarn "If for some reason this fails, try adding 'gtkhtml' to your USE variables, re-emerge gtk-sharp, then emerge monodoc"
+ die "make failed"
+ }
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}