summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/umockdev/umockdev-0.2.1.ebuild')
-rw-r--r--dev-util/umockdev/umockdev-0.2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/umockdev/umockdev-0.2.1.ebuild b/dev-util/umockdev/umockdev-0.2.1.ebuild
new file mode 100644
index 000000000000..fa715f637ece
--- /dev/null
+++ b/dev-util/umockdev/umockdev-0.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/umockdev/umockdev-0.2.1.ebuild,v 1.1 2013/03/15 01:09:15 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit python-any-r1 autotools-utils
+
+DESCRIPTION="Mock hardware devices for creating unit tests"
+HOMEPAGE="https://github.com/martinpitt/umockdev/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV:0:3}/+download/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RDEPEND="virtual/udev[gudev]
+ >=dev-libs/glib-2.24:2"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${P}-make.patch )
+AUTOTOOLS_AUTORECONF=1