summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/hub/hub-1.11.1.ebuild')
-rw-r--r--dev-vcs/hub/hub-1.11.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-vcs/hub/hub-1.11.1.ebuild b/dev-vcs/hub/hub-1.11.1.ebuild
new file mode 100644
index 000000000000..7fe6d08a6c4e
--- /dev/null
+++ b/dev-vcs/hub/hub-1.11.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/hub-1.11.1.ebuild,v 1.1 2014/01/15 22:18:22 ottxor Exp $
+
+EAPI="5"
+
+USE_RUBY="ruby18 ruby19"
+RUBY_FAKEGEM_TASK_DOC=
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit readme.gentoo ruby-fakegem
+
+ruby_add_bdepend "test? ( dev-ruby/webmock dev-util/cucumber )"
+
+DESCRIPTION="command-line wrapper for git that makes you better at GitHub"
+HOMEPAGE="https://github.com/github/hub"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+RDEPEND="dev-vcs/git"
+
+DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
+
+src_install() {
+ ruby-ng_src_install
+ readme.gentoo_create_doc
+}