summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/burgerspace/burgerspace-1.8.1.ebuild')
-rw-r--r--games-arcade/burgerspace/burgerspace-1.8.1.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/games-arcade/burgerspace/burgerspace-1.8.1.ebuild b/games-arcade/burgerspace/burgerspace-1.8.1.ebuild
index 65a6f1c0e637..9101b6f14530 100644
--- a/games-arcade/burgerspace/burgerspace-1.8.1.ebuild
+++ b/games-arcade/burgerspace/burgerspace-1.8.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/burgerspace/burgerspace-1.8.1.ebuild,v 1.7 2006/09/20 16:41:27 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/burgerspace/burgerspace-1.8.1.ebuild,v 1.8 2007/02/03 09:13:06 nyhm Exp $
-inherit games
+inherit autotools eutils games
DESCRIPTION="Clone of the 1982 BurgerTime video game by Data East"
HOMEPAGE="http://www3.sympatico.ca/sarrazip/dev/burgerspace.html"
@@ -13,18 +13,20 @@ SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86"
IUSE=""
-DEPEND=">=media-libs/libsdl-1.2.4
- >=media-libs/sdl-image-1.2
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
media-libs/sdl-mixer
dev-games/flatzebra"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ AT_M4DIR=macros eautoreconf
+}
+
src_install() {
- egamesinstall \
- docdir="${D}/usr/share/doc/${PF}" \
- desktopentrydir="${D}/usr/share/applications" \
- pixmapdir="${D}/usr/share/pixmaps" \
- || die
- rm -f "${D}/usr/share/doc/${PF}"/{COPYING,INSTALL}
- prepalldocs
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS HACKING NEWS README THANKS TODO
prepgamesdirs
}