summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/advancemenu/files')
-rw-r--r--games-emulation/advancemenu/files/advancemenu-2.4.13-alsa-pkg-config.patch44
-rw-r--r--games-emulation/advancemenu/files/advancemenu-2.4.13-gcc4.patch20
-rw-r--r--games-emulation/advancemenu/files/digest-advancemenu-2.4.133
3 files changed, 67 insertions, 0 deletions
diff --git a/games-emulation/advancemenu/files/advancemenu-2.4.13-alsa-pkg-config.patch b/games-emulation/advancemenu/files/advancemenu-2.4.13-alsa-pkg-config.patch
new file mode 100644
index 000000000000..de0af21f2fc0
--- /dev/null
+++ b/games-emulation/advancemenu/files/advancemenu-2.4.13-alsa-pkg-config.patch
@@ -0,0 +1,44 @@
+Make sure we ask alsa what libraries it needs rather than assuming.
+
+http://bugs.gentoo.org/97628
+
+Changes for configure.ac:
+ --------------------------------------
+ [snd_pcm_open],
+ [ac_lib_alsa=yes],
+ [ac_lib_alsa=no],
+ - [-lm]
+ + [`pkg-config alsa --libs`]
+ )
+ if test $ac_lib_alsa = yes; then
+ AC_MSG_CHECKING([for ALSA])
+ --------------------------------------
+ [snd_pcm_open],
+ [],
+ [AC_MSG_ERROR([the ALSA library is missing])],
+ - [-lm]
+ + [`pkg-config alsa --libs`]
+ )
+ AC_MSG_CHECKING([for ALSA version])
+ AC_TRY_COMPILE([
+
+--- configure
++++ configure
+@@ -8298,7 +8298,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lasound -lm
++LIBS="-lasound `pkg-config alsa --libs`
+ $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+@@ -8428,7 +8428,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lasound -lm
++LIBS="-lasound `pkg-config alsa --libs`
+ $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
diff --git a/games-emulation/advancemenu/files/advancemenu-2.4.13-gcc4.patch b/games-emulation/advancemenu/files/advancemenu-2.4.13-gcc4.patch
new file mode 100644
index 000000000000..bf70b7eb12f8
--- /dev/null
+++ b/games-emulation/advancemenu/files/advancemenu-2.4.13-gcc4.patch
@@ -0,0 +1,20 @@
+--- ./advancemenu-2.4.13/advance/menu/emulator.h.old 2005-12-04 10:30:17.000000000 +0100
++++ ./advancemenu-2.4.13/advance/menu/emulator.h 2006-01-28 13:34:22.000000000 +0100
+@@ -41,7 +41,7 @@
+ tristate_t exclude_missing_effective;
+ tristate_t exclude_missing_orig;
+
+- std::string emulator::attrib_compile(const std::string& value0, const std::string& value1);
++ std::string attrib_compile(const std::string& value0, const std::string& value1);
+
+ std::string name;
+
+@@ -363,7 +363,7 @@
+ };
+
+ class generic : public emulator {
+- bool generic::load_info(game_set& gar);
++ bool load_info(game_set& gar);
+ public:
+ generic(const std::string& Aname, const std::string& Aexe_path, const std::string& Acmd_arg);
+
diff --git a/games-emulation/advancemenu/files/digest-advancemenu-2.4.13 b/games-emulation/advancemenu/files/digest-advancemenu-2.4.13
new file mode 100644
index 000000000000..55dd50eeeeae
--- /dev/null
+++ b/games-emulation/advancemenu/files/digest-advancemenu-2.4.13
@@ -0,0 +1,3 @@
+MD5 c75e4254cb9159c18ccb521c0b5aae47 advancemenu-2.4.13.tar.gz 2235347
+RMD160 57d28f8dfb082e4416777707fce2fbb6c5aa72f4 advancemenu-2.4.13.tar.gz 2235347
+SHA256 1e5099ff3aadc07153153a7c898c987b20f69a67740e05d6d21fc4582c4a685b advancemenu-2.4.13.tar.gz 2235347