summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/doom3/doom3-1.1.1286.ebuild')
-rw-r--r--games-fps/doom3/doom3-1.1.1286.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/games-fps/doom3/doom3-1.1.1286.ebuild b/games-fps/doom3/doom3-1.1.1286.ebuild
index d9e0b5d2df39..1381d4551bd0 100644
--- a/games-fps/doom3/doom3-1.1.1286.ebuild
+++ b/games-fps/doom3/doom3-1.1.1286.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/doom3-1.1.1286.ebuild,v 1.3 2005/04/18 15:20:31 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/doom3-1.1.1286.ebuild,v 1.4 2005/06/29 00:35:11 vapier Exp $
inherit eutils games
@@ -13,12 +13,12 @@ SRC_URI="mirror://3dgamers/3dgamers/games/${PN}/${PN}-linux-${PV}.x86.run
LICENSE="DOOM3"
SLOT="0"
KEYWORDS="-* x86 amd64"
-IUSE="cdinstall alsa opengl dedicated"
+IUSE="nocd alsa opengl dedicated"
RESTRICT="nostrip"
DEPEND="app-arch/bzip2
app-arch/tar"
-RDEPEND="virtual/libc
+RDEPEND="sys-libs/glibc
opengl? ( virtual/opengl )
dedicated? ( app-misc/screen )
alsa? ( >=media-libs/alsa-lib-1.0.6 )"
@@ -30,7 +30,7 @@ Ddir=${D}/${dir}
pkg_setup() {
check_license
- use cdinstall && cdrom_get_cds Setup/Data/base/pak002.pk4 \
+ use nocd && cdrom_get_cds Setup/Data/base/pak002.pk4 \
Setup/Data/base/pak000.pk4 \
Setup/Data/base/pak003.pk4
games_pkg_setup
@@ -58,7 +58,7 @@ src_install() {
insinto ${dir}/base
doins base/* || die "doins base"
- if use cdinstall; then
+ if use nocd; then
einfo "Copying files from Disk 1..."
doins ${CDROM_ROOT}/Setup/Data/base/pak002.pk4 \
|| die "copying pak002"
@@ -75,7 +75,7 @@ src_install() {
games_make_wrapper doom3 ./doom.x86 ${dir}
games_make_wrapper doom3-ded ./doomded.x86 ${dir}
- use cdinstall && find ${Ddir} -exec touch '{}' \;
+ use nocd && find ${Ddir} -exec touch '{}' \;
insinto /usr/share/pixmaps
doins doom3.png
@@ -87,7 +87,7 @@ src_install() {
pkg_postinst() {
games_pkg_postinst
- if use cdinstall; then
+ if use nocd; then
einfo "To play the game run:"
einfo " doom3"
else