summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/arts/arts-1.1.2-r1.ebuild')
-rw-r--r--kde-base/arts/arts-1.1.2-r1.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/kde-base/arts/arts-1.1.2-r1.ebuild b/kde-base/arts/arts-1.1.2-r1.ebuild
index 4c562176b332..f4df8457999f 100644
--- a/kde-base/arts/arts-1.1.2-r1.ebuild
+++ b/kde-base/arts/arts-1.1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.1.2-r1.ebuild,v 1.3 2003/09/06 23:54:21 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.1.2-r1.ebuild,v 1.4 2003/09/11 01:16:25 msterret Exp $
inherit kde-base flag-o-matic
IUSE="alsa oggvorbis artswrappersuid mad"
@@ -15,10 +15,10 @@ DESCRIPTION="aRts, the KDE sound (and all-around multimedia) server/output manag
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
newdepend "alsa? ( media-libs/alsa-lib )
- oggvorbis? ( media-libs/libvorbis media-libs/libogg )
- mad? ( media-sound/mad )
- media-libs/audiofile
- >=dev-libs/glib-2"
+ oggvorbis? ( media-libs/libvorbis media-libs/libogg )
+ mad? ( media-sound/mad )
+ media-libs/audiofile
+ >=dev-libs/glib-2"
if [ "${COMPILER}" == "gcc3" ]; then
# GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
@@ -69,12 +69,12 @@ CONFIG_PROTECT=${PREFIX}/share/config" > ${D}/etc/env.d/49kdepaths-3.1.2 # numbe
pkg_postinst() {
-if [ -z "`use artswrappersuid`" ]; then
- einfo "Run chmod +s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
- einfo "and so avoid possible skips in sound. However, on untrusted systems this"
- einfo "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
- einfo "priority, and so is off by default. See bug #7883."
- einfo "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
-fi
+ if [ -z "`use artswrappersuid`" ]; then
+ einfo "Run chmod +s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
+ einfo "and so avoid possible skips in sound. However, on untrusted systems this"
+ einfo "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ einfo "priority, and so is off by default. See bug #7883."
+ einfo "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
+ fi
}