summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.5.2.ebuild')
-rw-r--r--kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.5.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.5.2.ebuild b/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.5.2.ebuild
new file mode 100644
index 000000000000..d9c457261272
--- /dev/null
+++ b/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.5.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.5.2.ebuild,v 1.1 2006/03/22 20:14:53 danarmak Exp $
+
+KMNAME=kdemultimedia
+KMMODULE=mpeglib_artsplug
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="mpeglib plugin for arts"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND="$(deprange 3.5.1 $MAXKDEVER kde-base/mpeglib)"
+
+KMCOPYLIB="libmpeg mpeglib/lib/"
+KMEXTRACTONLY="mpeglib/"
+
+pkg_setup() {
+ if ! useq arts; then
+ eerror "${PN} needs the USE=\"arts\" enabled and also the kdelibs compiled with the USE=\"arts\" enabled"
+ die
+ fi
+}