summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kmail/kmail-4.4.11.1-r1.ebuild')
-rw-r--r--kde-base/kmail/kmail-4.4.11.1-r1.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/kde-base/kmail/kmail-4.4.11.1-r1.ebuild b/kde-base/kmail/kmail-4.4.11.1-r1.ebuild
new file mode 100644
index 000000000000..f86926ce61c3
--- /dev/null
+++ b/kde-base/kmail/kmail-4.4.11.1-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.4.11.1-r1.ebuild,v 1.1 2012/08/01 22:54:54 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdepim"
+KDE_HANDBOOK=optional
+VIRTUALX_REQUIRED=test
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop' 4.6)
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop' 4.6)
+ $(add_kdebase_dep libkdepim '' 4.4.11.1-r1)
+ $(add_kdebase_dep libkleo)
+ $(add_kdebase_dep libkpgp)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+add_blocker kmailcvt
+add_blocker libksieve
+add_blocker messagecore
+add_blocker messagelist
+add_blocker messageviewer
+add_blocker mimelib
+
+KMEXTRACTONLY="
+ korganizer/org.kde.Korganizer.Calendar.xml
+ libkleo/
+ libkpgp/
+"
+KMEXTRA="
+ kmailcvt/
+ ksendemail/
+ libksieve/
+ messagecore/
+ messagelist/
+ messageviewer/
+ mimelib/
+ plugins/kmail/
+"
+KMLOADLIBS="libkdepim"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4.9-nodbus.patch"
+ "${FILESDIR}/4.4/"000{2,4,5}-*.patch
+)
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ mycmakeargs=(
+ -DWITH_IndicateQt=OFF
+ )
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ kde4-meta_src_compile kmail_xml
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+ if ! has_version kde-base/kleopatra:${SLOT}; then
+ echo
+ elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
+ echo
+ fi
+}