summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kwin/kwin-4.3.3.ebuild')
-rw-r--r--kde-base/kwin/kwin-4.3.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/kde-base/kwin/kwin-4.3.3.ebuild b/kde-base/kwin/kwin-4.3.3.ebuild
new file mode 100644
index 000000000000..75f89852efcc
--- /dev/null
+++ b/kde-base/kwin/kwin-4.3.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.3.3.ebuild,v 1.1 2009/11/02 21:54:42 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug xcomposite xinerama"
+
+# NOTE disabled for now: captury? ( media-libs/libcaptury )
+COMMONDEPEND="
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep libkworkspace)
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_prepare() {
+# NOTE uncomment when enabled again by upstream
+# if ! use captury; then
+# sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+# -i kwin/effects/CMakeLists.txt || \
+# die "Making captury optional failed."
+# fi
+ # Dirty hax to fix building without OpenGL
+ if ! use opengl; then
+ sed -e 's|^[[:space:]]*windowOpacity.*|// commented out &|' \
+ -i kwin/effects/logout/logout.cpp || \
+ die "Commenting out windowOpacity failed."
+ fi
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)"
+
+ kde4-meta_src_configure
+}