summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/marble/files/marble-4.9.1-shapelib.patch')
-rw-r--r--kde-base/marble/files/marble-4.9.1-shapelib.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/kde-base/marble/files/marble-4.9.1-shapelib.patch b/kde-base/marble/files/marble-4.9.1-shapelib.patch
new file mode 100644
index 000000000000..2f86c7378b8f
--- /dev/null
+++ b/kde-base/marble/files/marble-4.9.1-shapelib.patch
@@ -0,0 +1,13 @@
+diff --git a/src/plugins/runner/CMakeLists.txt b/src/plugins/runner/CMakeLists.txt
+index 4ab295a..0b82fa7 100644
+--- a/src/plugins/runner/CMakeLists.txt
++++ b/src/plugins/runner/CMakeLists.txt
+@@ -26,7 +26,7 @@ add_subdirectory( osm )
+ add_subdirectory( pnt )
+ add_subdirectory( log )
+
+-find_package( libshp )
++macro_optional_find_package( libshp )
+ if( LIBSHP_FOUND )
+ add_subdirectory( shp )
+ endif( LIBSHP_FOUND )