summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/step/step-4.3.3.ebuild')
-rw-r--r--kde-base/step/step-4.3.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-base/step/step-4.3.3.ebuild b/kde-base/step/step-4.3.3.ebuild
new file mode 100644
index 000000000000..9ee2cf1b61e3
--- /dev/null
+++ b/kde-base/step/step-4.3.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.3.3.ebuild,v 1.1 2009/11/02 22:13:03 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug +handbook +gsl +qalculate"
+
+DEPEND="
+ >=dev-cpp/eigen-2.0.3
+ sci-libs/cln
+ >=sci-mathematics/gmm-3.0
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with qalculate)"
+
+ kde4-meta_src_configure
+}