summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/feh/feh-1.15.ebuild')
-rw-r--r--media-gfx/feh/feh-1.15.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-gfx/feh/feh-1.15.ebuild b/media-gfx/feh/feh-1.15.ebuild
new file mode 100644
index 000000000000..d014856bee96
--- /dev/null
+++ b/media-gfx/feh/feh-1.15.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/feh-1.15.ebuild,v 1.1 2011/08/16 03:42:26 radhermit Exp $
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="A fast, lightweight imageviewer using imlib2"
+HOMEPAGE="http://feh.finalrewind.org/"
+SRC_URI="http://feh.finalrewind.org/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug curl test xinerama"
+
+COMMON_DEPEND=">=media-libs/giblib-1.2.4
+ media-libs/imlib2
+ >=media-libs/libpng-1.4
+ x11-libs/libX11
+ curl? ( net-misc/curl )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/jpeg"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/libXt
+ x11-proto/xproto
+ test? ( >=dev-lang/perl-5.10
+ dev-perl/Test-Command )"
+
+feh_use() {
+ if use ${1}; then
+ echo 1
+ else
+ echo 0
+ fi
+}
+
+pkg_setup() {
+ fehopts=(
+ DESTDIR="${D}"
+ PREFIX=/usr
+ doc_dir='${main_dir}'/share/doc/${PF}
+ example_dir='${main_dir}'/share/doc/${PF}/examples
+ debug=$(feh_use debug)
+ curl=$(feh_use curl)
+ xinerama=$(feh_use xinerama)
+ )
+}
+
+src_compile() {
+ tc-export CC
+ emake "${fehopts[@]}"
+}
+
+src_install() {
+ emake "${fehopts[@]}" install
+}