summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/zphoto/zphoto-1.2-r2.ebuild')
-rw-r--r--media-gfx/zphoto/zphoto-1.2-r2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/media-gfx/zphoto/zphoto-1.2-r2.ebuild b/media-gfx/zphoto/zphoto-1.2-r2.ebuild
index 15a6a499985a..512b750f75ba 100644
--- a/media-gfx/zphoto/zphoto-1.2-r2.ebuild
+++ b/media-gfx/zphoto/zphoto-1.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/zphoto-1.2-r2.ebuild,v 1.5 2009/07/20 18:21:39 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/zphoto-1.2-r2.ebuild,v 1.6 2009/07/20 19:33:41 vostorga Exp $
EAPI=2
@@ -21,28 +21,27 @@ DEPEND=">=media-libs/ming-0.2a
app-arch/zip
>=dev-libs/popt-1.6.3
wxwindows? ( =x11-libs/wxGTK-2.6*[X] )"
-RDEPEND=""
+RDEPEND="${DEPEND}"
src_prepare(){
#bug 273831
epatch "${FILESDIR}"/"${P}"-glibc210.patch
}
-src_compile() {
+src_configure() {
local myconf="${myconf} --disable-avifile"
if use wxwindows ; then
WX_GTK_VER="2.6"
need-wxwidgets gtk2
- myconf="--with-wx-config=${WX_CONFIG}"
+ myconf="${myconf} --with-wx-config=${WX_CONFIG}"
sed -i -e 's@FALSE@false@g' wxzphoto.cpp || die
else
- myconf="--disable-wx"
+ myconf="${myconf} --disable-wx"
fi
econf ${myconf}
- emake || die
}
src_install() {