summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libgpod/libgpod-0.6.0.ebuild')
-rw-r--r--media-libs/libgpod/libgpod-0.6.0.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/media-libs/libgpod/libgpod-0.6.0.ebuild b/media-libs/libgpod/libgpod-0.6.0.ebuild
deleted file mode 100644
index 288c4939caae..000000000000
--- a/media-libs/libgpod/libgpod-0.6.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.6.0.ebuild,v 1.13 2009/03/10 17:40:52 tester Exp $
-
-inherit eutils libtool
-
-DESCRIPTION="Shared library to access the contents of an iPod"
-HOMEPAGE="http://www.gtkpod.org/libgpod.html"
-SRC_URI="mirror://sourceforge/gtkpod/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ppc64 sparc x86"
-IUSE="gtk python doc test hal"
-
-RDEPEND=">=dev-libs/glib-2.4
- hal? ( =sys-apps/hal-0.5* )
- sys-apps/sg3_utils
- gtk? ( >=x11-libs/gtk+-2 )
- python? ( >=dev-lang/python-2.3
- >=x11-libs/gtk+-2
- media-libs/mutagen
- gtk? ( >=dev-python/pygobject-2 ) )
- test? ( media-libs/taglib )"
-DEPEND="${RDEPEND}
- doc? ( dev-util/gtk-doc )
- python? ( >=dev-lang/swig-1.3.24 )
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}+gcc-4.3.patch"
-
- elibtoolize
-}
-
-src_compile() {
- econf \
- $(use_enable doc gtk-doc) \
- $(use_enable gtk gdk-pixbuf) \
- $(use_with hal hal) \
- $(use_enable python) \
- $(use_with python) || die "configure failed"
-
- emake || die "make failed"
-
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc README TROUBLESHOOTING AUTHORS NEWS README.SysInfo
-}
-
-pkg_postinst() {
- einfo "If you use a newer Ipod like the Ipod classic, make sure to read"
- einfo "the information in README.SysInfo in /usr/share/doc/${P}"
- einfo "This is no needed if HAL is installed and works correctly."
-}