summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/smpeg2/smpeg2-2.0.0-r1.ebuild')
-rw-r--r--media-libs/smpeg2/smpeg2-2.0.0-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/media-libs/smpeg2/smpeg2-2.0.0-r1.ebuild b/media-libs/smpeg2/smpeg2-2.0.0-r1.ebuild
deleted file mode 100644
index b12a1349abf7..000000000000
--- a/media-libs/smpeg2/smpeg2-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg2/smpeg2-2.0.0-r1.ebuild,v 1.1 2013/10/07 15:36:12 hasufell Exp $
-
-EAPI=5
-inherit eutils toolchain-funcs autotools
-
-MY_P=smpeg-${PV}
-DESCRIPTION="SDL MPEG Player Library"
-HOMEPAGE="http://icculus.org/smpeg/"
-SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug mmx static-libs"
-
-DEPEND="media-libs/libsdl2"
-RDEPEND="${DEPEND}"
-
-DOCS=( CHANGES README README.SDL_mixer TODO )
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-smpeg2-config.patch
-
- # avoid file collision with media-libs/smpeg
- sed -i \
- -e '/plaympeg/d' \
- Makefile.am || die
-
- AT_M4DIR="/usr/share/aclocal acinclude" eautoreconf
-}
-
-src_configure() {
- tc-export CC CXX RANLIB AR
-
- # the debug option is bogus ... all it does is add extra
- # optimizations if you pass --disable-debug
- econf \
- $(use_enable static-libs static) \
- --disable-rpath \
- --enable-debug \
- --disable-sdltest \
- $(use_enable mmx) \
- $(use_enable debug assertions)
-}
-
-src_install() {
- default
- use static-libs || prune_libtool_files
-}