summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/capseo/ChangeLog8
-rw-r--r--media-libs/capseo/capseo-0.3.0_pre200706031.ebuild4
-rw-r--r--media-libs/capseo/capseo-0.3.0_pre200712251.ebuild93
-rw-r--r--media-libs/capseo/files/digest-capseo-0.3.0_pre2007122513
-rw-r--r--media-libs/libcaptury/ChangeLog8
-rw-r--r--media-libs/libcaptury/files/digest-libcaptury-0.3.0_pre2007122513
-rw-r--r--media-libs/libcaptury/libcaptury-0.3.0_pre200706031.ebuild4
-rw-r--r--media-libs/libcaptury/libcaptury-0.3.0_pre200712251.ebuild92
8 files changed, 209 insertions, 6 deletions
diff --git a/media-libs/capseo/ChangeLog b/media-libs/capseo/ChangeLog
index 49df54fb7cac..1da6aba451a7 100644
--- a/media-libs/capseo/ChangeLog
+++ b/media-libs/capseo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/capseo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/capseo/ChangeLog,v 1.2 2007/07/01 22:26:30 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/capseo/ChangeLog,v 1.3 2007/12/25 17:59:52 trapni Exp $
+
+*capseo-0.3.0_pre200712251 (25 Dec 2007)
+
+ 25 Dec 2007; Christian Parpart <trapni@gentoo.org>
+ +capseo-0.3.0_pre200712251.ebuild:
+ snapshot bump
01 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
capseo-0.3.0_pre200706031.ebuild:
diff --git a/media-libs/capseo/capseo-0.3.0_pre200706031.ebuild b/media-libs/capseo/capseo-0.3.0_pre200706031.ebuild
index 137377397b9e..de05894cadf4 100644
--- a/media-libs/capseo/capseo-0.3.0_pre200706031.ebuild
+++ b/media-libs/capseo/capseo-0.3.0_pre200706031.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/capseo/capseo-0.3.0_pre200706031.ebuild,v 1.2 2007/07/01 22:26:30 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/capseo/capseo-0.3.0_pre200706031.ebuild,v 1.3 2007/12/25 17:59:52 trapni Exp $
inherit flag-o-matic multilib
@@ -37,7 +37,7 @@ src_compile() {
return
fi
- cd ${S} || die
+ cd "${S}" || die
if [[ ! -f configure ]]; then
./autogen.sh || die "autogen.sh failed"
diff --git a/media-libs/capseo/capseo-0.3.0_pre200712251.ebuild b/media-libs/capseo/capseo-0.3.0_pre200712251.ebuild
new file mode 100644
index 000000000000..75a7cd9bf5a1
--- /dev/null
+++ b/media-libs/capseo/capseo-0.3.0_pre200712251.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/capseo/capseo-0.3.0_pre200712251.ebuild,v 1.1 2007/12/25 17:59:52 trapni Exp $
+
+inherit flag-o-matic multilib
+
+DESCRIPTION="Capseo Video Codec Library"
+HOMEPAGE="http://rm-rf.in/captury/wiki/CapseoCodec"
+SRC_URI="http://upstream.rm-rf.in/captury/captury-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug theora"
+
+RDEPEND=">=media-libs/libtheora-1.0_alpha6-r1"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/yasm-0.4.0
+ dev-util/pkgconfig"
+
+EMULTILIB_PKG="true"
+
+S="${WORKDIR}/captury-${PV}/${PN}"
+
+src_compile() {
+ if [[ -z ${OABI} ]] && has_multilib_profile; then
+ use debug && append-flags -O0 -g3
+ use debug || append-flags -DNDEBUG=1
+
+ einfo "Building multilib ${PN} for ABIs: $(get_install_abis)"
+ OABI=${ABI}
+ for ABI in $(get_install_abis); do
+ export ABI=${ABI}
+ src_compile
+ done
+ ABI=${OABI}
+ return
+ fi
+
+ cd "${S}" || die
+
+ if [[ ! -f configure ]]; then
+ ./autogen.sh || die "autogen.sh failed"
+ fi
+
+ # obviousely in src_install() it is set to "default" on non-multilib hosts,
+ # but isn't in src_compile()
+ ABI=${ABI:-default}
+
+ mkdir abi-${ABI}
+ cd abi-${ABI}
+
+ local myconf=
+ case ${ABI} in
+ amd64|x86)
+ myconf="${myconf} --with-accel=${ABI}"
+ ;;
+ esac
+ myconf="${myconf} $(use_enable theora)"
+
+ ../configure ${myconf} \
+ --prefix="/usr" \
+ --host="$(get_abi_CHOST ${ABI})" \
+ --libdir="/usr/$(get_libdir)" \
+ || die "./configure for ABI ${ABI} failed"
+
+ emake || die "make for ABI ${ABI} failed"
+}
+
+src_install() {
+ for ABI in $(get_install_abis); do
+ make -C abi-${ABI} install DESTDIR="${D}" || die "make install for ABI ${ABI} failed."
+ done
+
+ rm "${D}/usr/bin/cpsplay" # currently unsupported
+
+ dodoc AUTHORS ChangeLog* NEWS README* TODO
+}
+
+pkg_postinst() {
+ einfo "Use the following command to re-encode your screen captures to a"
+ einfo "file format current media players do understand:"
+ einfo
+ einfo " cpsrecode -i capture.cps -o - | mencoder - -o capture.avi \\"
+ einfo " -ovc lavc -lavcopts vcodec=xvid:autoaspect=1"
+ einfo
+ einfo "or if use-flag theora enabled, create your ogg/theora file inplace:"
+ einfo
+ einfo " cpsrecode -i capture.cps -o capture.ogg -c theora"
+ echo
+}
+
+# vim:ai:noet:ts=4:nowrap
diff --git a/media-libs/capseo/files/digest-capseo-0.3.0_pre200712251 b/media-libs/capseo/files/digest-capseo-0.3.0_pre200712251
new file mode 100644
index 000000000000..bce9f747eb7a
--- /dev/null
+++ b/media-libs/capseo/files/digest-capseo-0.3.0_pre200712251
@@ -0,0 +1,3 @@
+MD5 dc68b7105778ff708cf17aadeceb4b7b captury-0.3.0_pre200712251.tar.bz2 1256351
+RMD160 0527f5f18e84ada5b37941f7f55355c20ef0fc0e captury-0.3.0_pre200712251.tar.bz2 1256351
+SHA256 119499991c8bf68632485adce7bc13ce9b754d8b406862351abe8d92e3eb5fc3 captury-0.3.0_pre200712251.tar.bz2 1256351
diff --git a/media-libs/libcaptury/ChangeLog b/media-libs/libcaptury/ChangeLog
index d9fcb7c37c81..e088d0ab1ef8 100644
--- a/media-libs/libcaptury/ChangeLog
+++ b/media-libs/libcaptury/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libcaptury
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libcaptury/ChangeLog,v 1.3 2007/07/01 23:12:18 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcaptury/ChangeLog,v 1.4 2007/12/25 18:02:25 trapni Exp $
+
+*libcaptury-0.3.0_pre200712251 (25 Dec 2007)
+
+ 25 Dec 2007; Christian Parpart <trapni@gentoo.org>
+ +libcaptury-0.3.0_pre200712251.ebuild:
+ snapshot bump
01 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
libcaptury-0.3.0_pre200706031.ebuild:
diff --git a/media-libs/libcaptury/files/digest-libcaptury-0.3.0_pre200712251 b/media-libs/libcaptury/files/digest-libcaptury-0.3.0_pre200712251
new file mode 100644
index 000000000000..bce9f747eb7a
--- /dev/null
+++ b/media-libs/libcaptury/files/digest-libcaptury-0.3.0_pre200712251
@@ -0,0 +1,3 @@
+MD5 dc68b7105778ff708cf17aadeceb4b7b captury-0.3.0_pre200712251.tar.bz2 1256351
+RMD160 0527f5f18e84ada5b37941f7f55355c20ef0fc0e captury-0.3.0_pre200712251.tar.bz2 1256351
+SHA256 119499991c8bf68632485adce7bc13ce9b754d8b406862351abe8d92e3eb5fc3 captury-0.3.0_pre200712251.tar.bz2 1256351
diff --git a/media-libs/libcaptury/libcaptury-0.3.0_pre200706031.ebuild b/media-libs/libcaptury/libcaptury-0.3.0_pre200706031.ebuild
index 8346a5be3234..90f0539d322e 100644
--- a/media-libs/libcaptury/libcaptury-0.3.0_pre200706031.ebuild
+++ b/media-libs/libcaptury/libcaptury-0.3.0_pre200706031.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libcaptury/libcaptury-0.3.0_pre200706031.ebuild,v 1.3 2007/07/01 23:12:18 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcaptury/libcaptury-0.3.0_pre200706031.ebuild,v 1.4 2007/12/25 18:02:25 trapni Exp $
inherit multilib flag-o-matic
@@ -59,7 +59,7 @@ src_compile() {
return
fi
- cd ${S}
+ cd "${S}"
if [[ ! -f configure ]]; then
./autogen.sh || die "autogen.sh failed"
diff --git a/media-libs/libcaptury/libcaptury-0.3.0_pre200712251.ebuild b/media-libs/libcaptury/libcaptury-0.3.0_pre200712251.ebuild
new file mode 100644
index 000000000000..c37e8fe11502
--- /dev/null
+++ b/media-libs/libcaptury/libcaptury-0.3.0_pre200712251.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcaptury/libcaptury-0.3.0_pre200712251.ebuild,v 1.1 2007/12/25 18:02:25 trapni Exp $
+
+inherit multilib flag-o-matic
+
+DESCRIPTION="Captury Framework Library"
+HOMEPAGE="http://rm-rf.in/projects/captury/"
+SRC_URI="http://upstream.rm-rf.in./captury/captury-${PV}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug multilib"
+
+RDEPEND=">=media-libs/capseo-0.3.0_pre200712251
+ x11-libs/libX11
+ x11-libs/libXfixes
+ virtual/opengl
+ amd64? ( multilib? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-medialibs
+ ) )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+EMULTILIB_PKG="true"
+
+S="${WORKDIR}/captury-${PV}/${PN}"
+
+setup_env() {
+ LD_LIBRARY_PATH=
+ LDFLAGS=
+
+ # keep backwards compatibility as long as I *have* to.
+ if use amd64 && [[ ${ABI} = "x86" ]]; then
+ if has_version '<app-emulation/emul-linux-x86-xlibs-7.0-r8'; then
+ LDFLAGS="-L/emul/linux/x86/usr/lib"
+ LD_LIBRARY_PATH="/emul/linux/x86/usr/lib"
+ fi
+ fi
+
+ export LDFLAGS
+ export LD_LIBRARY_PATH
+}
+
+src_compile() {
+ if [[ -z ${OABI} ]] && has_multilib_profile; then
+ use debug && append-flags -O0 -g3
+ use debug || append-flags -DNDEBUG=1
+
+ einfo "Building multilib ${PN} for ABIs: $(get_install_abis)"
+ OABI=${ABI}
+ for ABI in $(get_install_abis); do
+ export ABI=${ABI}
+ src_compile
+ done
+ ABI=${OABI}
+ return
+ fi
+
+ cd "${S}"
+
+ if [[ ! -f configure ]]; then
+ ./autogen.sh || die "autogen.sh failed"
+ fi
+
+ ABI=${ABI:-default}
+
+ setup_env
+
+ mkdir abi-${ABI}
+ cd abi-${ABI}
+
+ ../configure \
+ --prefix="/usr" \
+ --host="$(get_abi_CHOST ${ABI})" \
+ --libdir="/usr/$(get_libdir)" \
+ || die "./configure for ABI ${ABI} failed"
+
+ emake || die "make for ABI ${ABI} failed"
+}
+
+src_install() {
+ for ABI in $(get_install_abis); do
+ make -C abi-${ABI} install DESTDIR="${D}" || die "make install for ABI ${ABI} failed."
+ done
+
+ dodoc AUTHORS ChangeLog* NEWS README* TODO
+}
+
+# vim:ai:noet:ts=4:nowrap