summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/darkice/darkice-0.13.ebuild')
-rw-r--r--media-sound/darkice/darkice-0.13.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/media-sound/darkice/darkice-0.13.ebuild b/media-sound/darkice/darkice-0.13.ebuild
index 9fdf9b35feaa..083201bc89ac 100644
--- a/media-sound/darkice/darkice-0.13.ebuild
+++ b/media-sound/darkice/darkice-0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/darkice-0.13.ebuild,v 1.3 2003/07/12 20:30:50 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/darkice-0.13.ebuild,v 1.4 2003/09/07 00:06:04 msterret Exp $
IUSE="encode oggvorbis"
@@ -19,10 +19,10 @@ DEPEND="encode? ( >=media-sound/lame-1.89 )
src_compile() {
local myconf=""
-
+
if [ ! "`use encode`" ] && [ ! "`use oggvorbis`" ]
then
-
+
eerror "You need support for mp3 or Ogg Vorbis enconding for this"
eerror "package. Please merge again with at least one of the "
eerror "\`encode' and \`oggvorbis' USE flags enabled:"
@@ -31,17 +31,17 @@ src_compile() {
eerror " # USE=\"oggvorbis\" emerge darkice"
die "Won't build without support for lame nor vorbis"
fi
-
+
use encode || myconf="--without-lame"
use oggvorbis || myconf="--without-vorbis"
-
+
econf ${myconf}
-
+
emake || die "Compilation failed"
}
src_install() {
einstall darkicedocdir=${D}/usr/share/doc/${PF} || die
-
+
dodoc AUTHORS ChangeLog COPYING NEWS README TODO
}