summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ati-drivers/ati-drivers-2.9.6.ebuild')
-rw-r--r--media-video/ati-drivers/ati-drivers-2.9.6.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/media-video/ati-drivers/ati-drivers-2.9.6.ebuild b/media-video/ati-drivers/ati-drivers-2.9.6.ebuild
index 2fc35d59bb98..f24e686d8ca2 100644
--- a/media-video/ati-drivers/ati-drivers-2.9.6.ebuild
+++ b/media-video/ati-drivers/ati-drivers-2.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ati-drivers/ati-drivers-2.9.6.ebuild,v 1.4 2003/07/12 21:12:31 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-drivers/ati-drivers-2.9.6.ebuild,v 1.5 2003/09/07 00:08:12 msterret Exp $
IUSE="qt kde gnome"
@@ -25,11 +25,11 @@ RESTRICT="nostrip"
src_unpack() {
if [ ! -f ${DISTDIR}/${A} ] ; then
die "Please download ${A} from ${HOMEPAGE} or http://www.schneider-digital.de/html/body_download_ati.html (fetch glx1_linux_X4.3.zip and unpack it)"
- fi
+ fi
cd ${WORKDIR}
#unpack ${A}
- #mv "./XFree 4.3.0-2.9.6/fglrx-glc22-4.3.0-${PV}.i586.rpm" .
- rpm2targz ${DISTDIR}/${A}
+ #mv "./XFree 4.3.0-2.9.6/fglrx-glc22-4.3.0-${PV}.i586.rpm" .
+ rpm2targz ${DISTDIR}/${A}
tar zxf fglrx-glc22-4.3.0-${PV}.i586.tar.gz
}
@@ -47,17 +47,17 @@ src_compile() {
sed -e 's:`id -u`:0:' make.sh >make.sh.new
sed -e 's:`uname -r`:${KV}:' make.sh.new >make.sh
chmod +x make.sh
- ./make.sh || ewarn "glx module not built"
-
+ ./make.sh || ewarn "glx module not built"
+
einfo "building the fgl_glxgears sample"
mkdir ${WORKDIR}/fglrxgears
cd ${WORKDIR}/fglrxgears
tar -xzvf ${WORKDIR}/usr/src/fglrx_sample_source.tgz
mv xc/programs/fgl_glxgears/* .
make -f Makefile.Linux || die
-
+
if [ "`use qt`" ]
- then
+ then
einfo "building the qt fglx panel"
cd ${WORKDIR}
local OLDBIN="/usr/X11R6/bin"
@@ -70,7 +70,7 @@ src_compile() {
mv Makefile.new Makefile
emake || die
fi
- #removing stuff
+ #removing stuff
einfo "cleaning"
cd ${WORKDIR}
rm -fR usr/share
@@ -85,19 +85,19 @@ pkg_preinst() {
then
rm -rf ${ROOT}/usr/lib/opengl/ati/*
fi
-}
+}
src_install() {
local ATI_ROOT="/usr/lib/opengl/ati"
cd ${WORKDIR}
-#drm module
+#drm module
insinto /lib/modules/${KV}/video
doins lib/modules/fglrx/build_mod/fglrx.o
#dri driver
exeinto ${ATI_ROOT}/lib
- doexe usr/X11R6/lib/libGL.so.1.2
+ doexe usr/X11R6/lib/libGL.so.1.2
dosym libGL.so.1.2 ${ATI_ROOT}/lib/libGL.so.1
dosym libGL.so.1.2 ${ATI_ROOT}/lib/libGL.so
dosym libGL.so.1.2 ${ATI_ROOT}/lib/libMesaGL.so
@@ -109,7 +109,7 @@ src_install() {
dosym ../xfree/include ${ATI_ROOT}/include
dosym ../xfree/extensions ${ATI_ROOT}/extensions
rm usr/X11R6/lib/libGL.so.1.2
-
+
#apps
insinto /etc/env.d
doins ${FILESDIR}/09ati
@@ -118,7 +118,7 @@ src_install() {
doexe usr/X11R6/bin/*
rm usr/X11R6/bin/*
- if [ "`use qt`" ]
+ if [ "`use qt`" ]
then
doexe fglrx_panel/fireglcontrol
fi