summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/camstream/camstream-0.26.3.ebuild')
-rw-r--r--media-video/camstream/camstream-0.26.3.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/media-video/camstream/camstream-0.26.3.ebuild b/media-video/camstream/camstream-0.26.3.ebuild
index 82bb04be51d5..adfe453ea7e7 100644
--- a/media-video/camstream/camstream-0.26.3.ebuild
+++ b/media-video/camstream/camstream-0.26.3.ebuild
@@ -1,18 +1,27 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/camstream/camstream-0.26.3.ebuild,v 1.2 2004/01/04 02:26:04 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/camstream/camstream-0.26.3.ebuild,v 1.3 2004/04/20 06:54:20 phosphan Exp $
DESCRIPTION="Collection of tools for webcams and other video devices"
HOMEPAGE="http://www.smcc.demon.nl/camstream/"
SRC_URI="http://www.smcc.demon.nl/camstream/download/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="~x86"
+KEYWORDS="x86"
SLOT="0"
IUSE="doc"
-# camstream configure script gets it wrong, sometimes
DEPEND=">=x11-libs/qt-3"
+src_compile () {
+ # Need to fake out Qt or we'll get sandbox problems
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+ econf || die "configure failed"
+ emake || die "emake failed"
+}
+
src_install () {
dobin camstream/camstream camstream/caminfo camstream/ftpput
dodir /usr/share/${PN}/icons