summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/mpv/mpv-0.6.2.ebuild')
-rw-r--r--media-video/mpv/mpv-0.6.2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-video/mpv/mpv-0.6.2.ebuild b/media-video/mpv/mpv-0.6.2.ebuild
index 6d34ce1a33e9..82bdecce0b3c 100644
--- a/media-video/mpv/mpv-0.6.2.ebuild
+++ b/media-video/mpv/mpv-0.6.2.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-0.6.2.ebuild,v 1.1 2014/11/14 22:46:27 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-0.6.2.ebuild,v 1.2 2015/01/03 12:22:14 mgorny Exp $
EAPI=5
EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
-inherit eutils waf-utils pax-utils fdo-mime gnome2-utils
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils python-any-r1 waf-utils pax-utils fdo-mime gnome2-utils
[[ ${PV} == *9999* ]] && inherit git-r3
WAF_V="1.7.16"
@@ -115,6 +118,7 @@ RDEPEND+="
)
"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=dev-lang/perl-5.8
dev-python/docutils
@@ -139,6 +143,8 @@ pkg_setup() {
einfo "For additional format support you need to enable the support on your"
einfo "libavcodec/libavformat provider:"
einfo " media-video/libav or media-video/ffmpeg"
+
+ python-any-r1_pkg_setup
}
src_unpack() {