summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/w3cam/w3cam-0.7.2.ebuild')
-rw-r--r--media-video/w3cam/w3cam-0.7.2.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/media-video/w3cam/w3cam-0.7.2.ebuild b/media-video/w3cam/w3cam-0.7.2.ebuild
index d16cda1e60cc..78f6cceeb561 100644
--- a/media-video/w3cam/w3cam-0.7.2.ebuild
+++ b/media-video/w3cam/w3cam-0.7.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/w3cam-0.7.2.ebuild,v 1.11 2006/03/07 17:21:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/w3cam-0.7.2.ebuild,v 1.12 2007/08/24 07:29:09 vapier Exp $
#
# You can set the default device that vidcat and w3camd use by setting
@@ -16,7 +16,7 @@ SRC_URI="http://mpx.freeshell.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc x86"
+KEYWORDS="~amd64 ~ppc x86"
IUSE="truetype"
DEPEND="sys-libs/zlib
@@ -24,21 +24,26 @@ DEPEND="sys-libs/zlib
media-libs/libpng
truetype? ( media-libs/freetype )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i '/-lpthread/s:$: $(LDFLAGS):' w3camd/Makefile.in
+}
+
src_compile() {
local myconf
-
- [[ -n "${W3CAM_DEVICE}" ]] && \
- myconf="${myconf} --with-device=${W3CAM_DEVICE}"
-
use truetype && \
myconf="${myconf} --with-ttf-inc=/usr/include/freetype"
- econf ${myconf} || die "econf failed"
+ econf \
+ --with-device=${W3CAM_DEVICE:-/dev/video0} \
+ ${myconf} \
+ || die "econf failed"
emake || die
}
src_install() {
- dobin vidcat w3camd/w3camd
+ dobin vidcat w3camd/w3camd || die
doman vidcat.1
dodoc ChangeLog.txt FAQ.txt README SAMPLES TODO.txt \
index.html w3cam.css w3cam.cgi w3cam.cgi.scf