summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/xvattr/xvattr-1.3-r1.ebuild')
-rw-r--r--media-video/xvattr/xvattr-1.3-r1.ebuild48
1 files changed, 27 insertions, 21 deletions
diff --git a/media-video/xvattr/xvattr-1.3-r1.ebuild b/media-video/xvattr/xvattr-1.3-r1.ebuild
index 0310b665fbe9..b761783d2abb 100644
--- a/media-video/xvattr/xvattr-1.3-r1.ebuild
+++ b/media-video/xvattr/xvattr-1.3-r1.ebuild
@@ -1,37 +1,43 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/xvattr/xvattr-1.3-r1.ebuild,v 1.8 2005/07/28 12:05:46 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xvattr/xvattr-1.3-r1.ebuild,v 1.9 2006/03/07 19:12:13 flameeyes Exp $
+
+inherit eutils autotools
DESCRIPTION="X11 XVideo Querying/Setting Tool from Ogle project"
HOMEPAGE="http://www.dtek.chalmers.se/groups/dvd/"
-SRC_URI="http://www.dtek.chalmers.se/groups/dvd/dist/${P}.tar.gz"
+SRC_URI="http://www.dtek.chalmers.se/groups/dvd/dist/${P}.tar.gz
+ mirror://gentoo/${P}-nogtk.patch.bz2"
LICENSE="GPL-2"
SLOT=0
KEYWORDS="~amd64 ~ppc x86"
IUSE="gtk"
-DEPEND="virtual/x11
- gtk? ( =x11-libs/gtk+-1.2*
- =dev-libs/glib-1.2* )"
+RDEPEND="
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXv
+ x11-libs/libXext
+ ) virtual/x11 )
+ gtk? (
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2* )"
+
+DEPEND="${RDEPEND}
+ || ( x11-libs/libXt virtual/x11 )"
src_unpack() {
unpack ${A}
- # If no gtk then modify the necessary parts so that gtk isn't needed anymore
- if ! use gtk
- then
- cd ${S}
- rm Makefile.in
- cp Makefile.am Makefile.am.orig
- sed -e "s/bin_PROGRAMS = xvattr gxvattr/bin_PROGRAMS = xvattr/" -e "s/gxvattr_SOURCES = gxvattr.c//" -e "s/CFLAGS = @GTK_CFLAGS@//" -e "s/gxvattr_LDADD = @GTK_LIBS@ \$(X_LIBS) \$(X_PRE_LIBS) \$(X_EXTRA_LIBS) -lX11 -lXext//" Makefile.am.orig >Makefile.am
- rm Makefile.am.orig
-
- cp configure.in configure.in.orig
- sed -e "s/dnl check for gtk//" -e "s/AM_PATH_GTK//" configure.in.orig >configure.in
- rm configure.in.orig
- automake
- autoconf
- fi
+ cd ${S}
+
+ epatch "${DISTDIR}/${P}-nogtk.patch.bz2"
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_compile() {
+ econf $(use_with gtk) || die "econf failed"
+ emake || die "emake failed"
}
src_install() {