summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nload/nload-0.5.0.ebuild')
-rw-r--r--net-analyzer/nload/nload-0.5.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/nload/nload-0.5.0.ebuild b/net-analyzer/nload/nload-0.5.0.ebuild
new file mode 100644
index 000000000000..fca38d6cb398
--- /dev/null
+++ b/net-analyzer/nload/nload-0.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nload/nload-0.5.0.ebuild,v 1.1 2002/09/03 08:34:46 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="console application which monitors network traffic and bandwidth usage in real time"
+SRC_URI="mirror://sourceforge/nload/${P}.tar.gz"
+HOMEPAGE="http://roland-riegel.de/nload/index_en.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 <${FILESDIR}/nload-0.5.0-gcc3-gentoo.patch
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --host=${CHOST} || die "./configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install
+ dodoc README INSTALL ChangeLog AUTHORS
+}
+