summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/pptpd/pptpd-1.3.2.ebuild')
-rw-r--r--net-dialup/pptpd/pptpd-1.3.2.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/net-dialup/pptpd/pptpd-1.3.2.ebuild b/net-dialup/pptpd/pptpd-1.3.2.ebuild
deleted file mode 100644
index 4263900391d3..000000000000
--- a/net-dialup/pptpd/pptpd-1.3.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpd/pptpd-1.3.2.ebuild,v 1.2 2006/05/12 21:58:28 mrness Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="Linux Point-to-Point Tunnelling Protocol Server"
-SRC_URI="mirror://sourceforge/poptop/${P}.tar.gz"
-HOMEPAGE="http://www.poptop.org/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="tcpd"
-
-DEPEND="net-dialup/ppp
- tcpd? ( sys-apps/tcp-wrappers )"
-
-src_unpack() {
- unpack ${A}
-
- epatch "${FILESDIR}/${P}-gentoo.patch"
- epatch "${FILESDIR}/${P}-connections-arg.patch"
-
- #Match pptpd-logwtmp.so's version with pppd's version (#89895)
- local PPPD_VER=`best_version net-dialup/ppp`
- PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
- PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
- sed -i -e "s:\\(#define[ \\t]*VERSION[ \\t]*\\)\".*\":\\1\"${PPPD_VER}\":" "${S}/plugins/patchlevel.h"
-
- eautomake
-}
-
-src_compile() {
- local myconf
- use tcpd && myconf="--with-libwrap"
- econf --enable-bcrelay \
- ${myconf} || die "configure failed"
- emake COPTS="${CFLAGS}" || die "make failed"
-}
-
-src_install () {
- einstall || die "make install failed"
-
- insinto /etc
- doins samples/pptpd.conf
-
- insinto /etc/ppp
- doins samples/options.pptpd
-
- exeinto /etc/init.d
- newexe "${FILESDIR}/pptpd-init" pptpd
-
- insinto /etc/conf.d
- newins "${FILESDIR}/pptpd-confd" pptpd
-
- dodoc AUTHORS ChangeLog NEWS README* TODO
- docinto samples
- dodoc samples/*
-}