summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/fwknop/fwknop-2.6.6.ebuild')
-rw-r--r--net-firewall/fwknop/fwknop-2.6.6.ebuild98
1 files changed, 98 insertions, 0 deletions
diff --git a/net-firewall/fwknop/fwknop-2.6.6.ebuild b/net-firewall/fwknop/fwknop-2.6.6.ebuild
new file mode 100644
index 000000000000..277614bb3005
--- /dev/null
+++ b/net-firewall/fwknop/fwknop-2.6.6.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/fwknop/fwknop-2.6.6.ebuild,v 1.1 2015/04/29 23:18:49 idella4 Exp $
+
+EAPI=5
+
+# Does work with python 2.7, does not work with python 3.3 on my machine
+# More feedback is welcome
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils distutils-r1 systemd
+
+DESCRIPTION="Single Packet Authorization and Port Knocking application"
+HOMEPAGE="http://www.cipherdyne.org/fwknop/"
+SRC_URI="https://github.com/mrash/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="client extras gdbm gpg python server udp-server"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ client? ( net-misc/wget[ssl] )
+ gpg? (
+ dev-libs/libassuan
+ dev-libs/libgpg-error
+ )"
+
+DEPEND="${RDEPEND}
+ gdbm? ( sys-libs/gdbm )
+ gpg? ( app-crypt/gpgme )
+ server? (
+ !udp-server? ( net-libs/libpcap )
+ net-firewall/iptables
+ )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ udp-server? ( server )"
+
+DOCS=( ChangeLog README.md )
+
+src_prepare() {
+ # Install example configs with .example suffix
+ if use server; then
+ sed -i 's/conf;/conf.example;/g' "${S}"/Makefile.am || die
+ fi
+
+ autotools-utils_src_prepare
+
+ if use python; then
+ cd "${S}"/python || die
+ distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/run
+ --enable-digest-cache
+ $(use_enable client)
+ $(use_enable !gdbm file-cache)
+ $(use_enable server)
+ $(use_enable udp-server)
+ $(use_with gpg gpgme)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use python; then
+ cd "${S}"/python || die
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+ prune_libtool_files --modules
+
+ if use server; then
+ newinitd "${FILESDIR}/fwknopd.init" fwknopd
+ newconfd "${FILESDIR}/fwknopd.confd" fwknopd
+ systemd_newtmpfilesd "${FILESDIR}/fwknopd.tmpfiles.conf" fwknopd.conf
+ fi
+
+ use extras && dodoc "${S}/extras/apparmor/usr.sbin.fwknopd"
+
+ if use python; then
+ # Unset DOCS since distutils-r1.eclass interferes
+ local DOCS=()
+ cd "${S}"/python || die
+ distutils-r1_src_install
+ fi
+}