summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/iptables/iptables-1.3.6-r1.ebuild')
-rw-r--r--net-firewall/iptables/iptables-1.3.6-r1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-firewall/iptables/iptables-1.3.6-r1.ebuild b/net-firewall/iptables/iptables-1.3.6-r1.ebuild
index 2d39e9d1e8b8..efabf580971b 100644
--- a/net-firewall/iptables/iptables-1.3.6-r1.ebuild
+++ b/net-firewall/iptables/iptables-1.3.6-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.6-r1.ebuild,v 1.2 2007/05/06 09:54:40 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.6-r1.ebuild,v 1.3 2008/06/14 14:04:51 zmedico Exp $
inherit eutils flag-o-matic toolchain-funcs linux-info
@@ -152,6 +152,11 @@ src_install() {
fi
}
+pkg_preinst() {
+ has_version "=${CATEGORY}/${PN}-1.2*"
+ upgrade_from_1_2_x=$?
+}
+
pkg_postinst() {
elog "This package now includes an initscript which loads and saves"
elog "rules stored in /var/lib/iptables/rules-save"
@@ -173,7 +178,7 @@ pkg_postinst() {
ewarn " net.ipv6.ip_forward = 1"
ewarn "for ipv6."
fi
- if has_version '=net-firewall/iptables-1.2*' ; then
+ if [[ $upgrade_from_1_2_x = 0 ]] ; then
echo
ewarn "When upgrading from iptables-1.2.x, you may be unable to remove"
ewarn "rules added with iptables-1.2.x. This is a known issue, please see:"