summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/vsftpd/files/vsftpd-2.3.2-as-needed.patch')
-rw-r--r--net-ftp/vsftpd/files/vsftpd-2.3.2-as-needed.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/net-ftp/vsftpd/files/vsftpd-2.3.2-as-needed.patch b/net-ftp/vsftpd/files/vsftpd-2.3.2-as-needed.patch
new file mode 100644
index 000000000000..330026e47e94
--- /dev/null
+++ b/net-ftp/vsftpd/files/vsftpd-2.3.2-as-needed.patch
@@ -0,0 +1,13 @@
+Index: vsftpd-2.3.2/Makefile
+===================================================================
+--- vsftpd-2.3.2.orig/Makefile
++++ vsftpd-2.3.2/Makefile
+@@ -21,7 +21,7 @@ OBJS = main.o utility.o prelogin.o ftpcm
+ $(CC) -c $*.c $(CFLAGS) $(IFLAGS)
+
+ vsftpd: $(OBJS)
+- $(CC) -o vsftpd $(OBJS) $(LINK) $(LIBS) $(LDFLAGS)
++ $(CC) -o vsftpd $(LDFLAGS) $(OBJS) $(LINK) $(LIBS)
+
+ install:
+ if [ -x /usr/local/sbin ]; then \