summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/gaim/gaim-0.75-r11.ebuild')
-rw-r--r--net-im/gaim/gaim-0.75-r11.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/net-im/gaim/gaim-0.75-r11.ebuild b/net-im/gaim/gaim-0.75-r11.ebuild
index 14c908407fea..d7fb1b0957b9 100644
--- a/net-im/gaim/gaim-0.75-r11.ebuild
+++ b/net-im/gaim/gaim-0.75-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.75-r11.ebuild,v 1.2 2004/03/26 14:33:36 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.75-r11.ebuild,v 1.3 2004/04/01 02:42:19 lv Exp $
inherit flag-o-matic eutils gcc
use debug && inherit debug
@@ -75,7 +75,18 @@ src_compile() {
local myconf
use perl || myconf="${myconf} --disable-perl"
use spell || myconf="${myconf} --disable-gtkspell"
- use nls || myconf="${myconf} --disable-nls"
+
+ # starting with gaim 0.75-r11, nls support depends on a version of
+ # gettext that isn't amd64-friendly
+ if [ `use amd64` ]
+ then
+ einfo "WARNING - nls support in gaim is disabled on amd64, see bug #46253"
+ myconf="${myconf} --disable-nls"
+ else
+ use_enable nls
+ fi
+ #use nls || myconf="${myconf} --disable-nls"
+
use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
NSS_LIB=/usr/lib