summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild')
-rw-r--r--net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild b/net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild
index 7874f9e0cb0e..b8f92c9bc0a6 100644
--- a/net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild
+++ b/net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild,v 1.7 2011/02/15 08:19:25 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/xchat-gnome-0.26.1-r1.ebuild,v 1.8 2011/03/09 16:18:31 ssuominen Exp $
EAPI="2"
GCONF_DEBUG="yes"
PYTHON_DEPEND="python? 2"
-inherit eutils gnome2 python toolchain-funcs
+inherit eutils gnome2 python
DESCRIPTION="GNOME frontend for the popular X-Chat IRC client"
HOMEPAGE="http://xchat-gnome.navi.cx/"
@@ -40,13 +40,6 @@ DEPEND="${RDEPEND}
# gnome-base/gnome-common needed when doing eautoreconf
pkg_setup() {
- if [[ $(gcc-major-version) -lt 4 || (
- $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 1 || (
- $(gcc-major-version) -eq 4 && $(gcc-minor-version) -eq 1 && $(gcc-micro-version) -lt 3 ) ) ]]; then
- ewarn "${P} requires >=sys-devel/gcc-4.1.3 to compile"
- die "Please select >=sys-devel/gcc-4.1.3"
- fi
-
# Per configure.ac, shm is disable because of upstream bug #565958
# --enable-shm
G2CONF="${G2CONF}
@@ -72,6 +65,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+
gnome2_src_prepare
# Fix build with it documentation, bug #341173