summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/xchat/xchat-1.8.7-r1.ebuild')
-rw-r--r--net-irc/xchat/xchat-1.8.7-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-irc/xchat/xchat-1.8.7-r1.ebuild b/net-irc/xchat/xchat-1.8.7-r1.ebuild
new file mode 100644
index 000000000000..d0e33f9cf4c2
--- /dev/null
+++ b/net-irc/xchat/xchat-1.8.7-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyrigth 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.7-r1.ebuild,v 1.1 2002/01/20 09:27:09 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is an IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+RDEPEND=">=x11-libs/gtk+-1.2.10-r4
+ python? ( >=dev-lang/python-2.2 )
+ perl? ( sys-devel/perl )
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ cp configure configure.orig
+ if [ "`use python`" ]
+ then
+ local mylibs=`/usr/bin/python-config`
+ sed -e 's:PY_LIBS=".*":PY_LIBS="'"$mylibs"'":' configure.orig > configure
+ fi
+}
+
+src_compile() {
+
+ local myopts myflags
+ use gnome && myopts="--enable-gnome --enable-panel"
+ use gnome || myopts="--enable-gtkfe --disable-gnome --disable-gdk-pixbuf --disable-zvt"
+ use ssl && myopts="$myopts --enable-openssl"
+ use perl || myopts="$myopts --disable-perl"
+ use python && myflags="`python-config`"
+ use python || myopts="$myopts --disable-python"
+ use nls || myopts="$myopts --disable-nls"
+ use mmx && myopts="$myopts --enable-mmx"
+
+ CFLAGS="$CFLAGS -I/usr/include/orbit-1.0"
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --enable-ipv6 \
+ ${myopts} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr install || die
+
+ dodoc AUTHORS COPYING ChangeLog README
+}