summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/wvstreams/wvstreams-3.70-r2.ebuild')
-rw-r--r--net-libs/wvstreams/wvstreams-3.70-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/wvstreams/wvstreams-3.70-r2.ebuild b/net-libs/wvstreams/wvstreams-3.70-r2.ebuild
new file mode 100644
index 000000000000..b0d216677f9b
--- /dev/null
+++ b/net-libs/wvstreams/wvstreams-3.70-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-3.70-r1.ebuild,v 1.1 2002/07/04 02:47:58 lostlogic Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A network programming library in C++"
+SRC_URI="http://open.nit.ca/download/${P}.tar.gz"
+HOMEPAGE="http://open.nit.ca/wvstreams"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-gentoo.patch || die "Patching failed"
+}
+
+src_compile() {
+ CFLAGS="${CFLAGS} -Wno-deprecated"
+ make || die
+}
+
+src_install() {
+
+ make \
+ PREFIX=${D}/usr \
+ install || die
+}