summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/dahdi-tools/dahdi-tools-2.5.0.ebuild')
-rw-r--r--net-misc/dahdi-tools/dahdi-tools-2.5.0.ebuild29
1 files changed, 12 insertions, 17 deletions
diff --git a/net-misc/dahdi-tools/dahdi-tools-2.5.0.ebuild b/net-misc/dahdi-tools/dahdi-tools-2.5.0.ebuild
index 408b2f6381b5..6081312e7944 100644
--- a/net-misc/dahdi-tools/dahdi-tools-2.5.0.ebuild
+++ b/net-misc/dahdi-tools/dahdi-tools-2.5.0.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dahdi-tools/dahdi-tools-2.5.0.ebuild,v 1.3 2012/04/22 12:22:15 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dahdi-tools/dahdi-tools-2.5.0.ebuild,v 1.4 2012/05/04 16:19:59 chainsaw Exp $
-EAPI=3
+EAPI=4
inherit base
DESCRIPTION="Userspace tools to configure the kernel modules from net-misc/dahdi"
HOMEPAGE="http://www.asterisk.org"
-SRC_URI="http://downloads.digium.com/pub/telephony/dahdi-tools/releases/${P}.tar.gz
- mirror://gentoo/gentoo-dahdi-tools-patchset-0.2.tar.bz2"
+SRC_URI="http://downloads.digium.com/pub/telephony/${PN}/releases/${P}.tar.gz
+ mirror://gentoo/gentoo-${PN}-patchset-0.2.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -25,25 +25,20 @@ DEPEND="dev-libs/newt
RDEPEND="${DEPEND}"
EPATCH_SUFFIX="diff"
-PATCHES=( "${WORKDIR}/dahdi-tools-patchset" )
+PATCHES=( "${WORKDIR}/${PN}-patchset" )
src_compile() {
default_src_compile
- emake tests || die "Failed compiling test utilities"
- if use ppp; then
- emake -C ppp || die "Failed compiling ppp plugin"
- fi
+ emake tests
+ use ppp && emake -C ppp
}
src_install() {
- emake DESTDIR="${D}" install || die "Failed to install binaries"
- if use ppp; then
- emake DESTDIR="${D}" -C ppp install || die "Failed to install ppp plugin"
- fi
- emake DESTDIR="${D}" config || die "Failed to install configuration files"
-
- dosbin patgen pattest patlooptest hdlcstress hdlctest hdlcgen
- dosbin hdlcverify timertest
+ emake DESTDIR="${D}" install
+ use ppp && emake DESTDIR="${D}" -C ppp install
+ emake DESTDIR="${D}" config
+
+ dosbin patgen pattest patlooptest hdlcstress hdlctest hdlcgen hdlcverify timertest
# install init scripts
newinitd "${FILESDIR}"/dahdi.init2 dahdi